ArcMap 10.1 crashes when opening mxd in previous version with maplex on

2383
7
10-22-2012 10:10 AM
ElizabethSiddorn
New Contributor
A lot of my maps were using the maplex extension for labelling.
We just upgraded to 10.1 and everytime I open a map that had maplex turned on the mxd crashes. 
If I get to the pause button ontime I can switch the properties back to the standard label engine, but it's getting rather frustrating.
Any fixes for this?
Tags (2)
0 Kudos
7 Replies
JustinConner
Occasional Contributor II
This apparently extends to feature-linked anno created with Maplex on. I have a ArcGIS 10 database that contains feature-linked anno created with Maplex. I upgraded to 10.1 SP1 and ArcMap crashes once either the feature class or the anno layer is added to the map. ArcCatalog also crashes when previewing either of them as well.
0 Kudos
TONIFAIRBANKS
New Contributor III
We are having the same problem.  Did anyone find a fix yet?
0 Kudos
JonMorris
Occasional Contributor II
This is very bad news. Opening at a previous version should not cause a crash, either for labeling or feature-linked annotation.

Could you post a sample of your data, or even better, submit a support request to ESRI Support Services? An analyst such as myself will then be happy to investigate the issue with you.
http://support.esri.com/en/
0 Kudos
AmyDaniels
New Contributor
I was wondering if there was a solution found for this issue.  I think I may also be having that problem.
Thanks,
Amy Daniels
Greenville Technical College
0 Kudos
JustinConner
Occasional Contributor II
There is a number it is: Incident #1104375

I worked with support and here was the resolution.

Given the fact that you were able to create a new sde geodatabase and import the same data into it and interact with the data in the versioned environment, I will mark this incident as resolved.



So basically, you need to make a new database and copy the data over to the new one. This wasnt a big deal for me as I had a new server and was coping data anyway.
0 Kudos
MichaelOlkin
New Contributor III
It is absolutely absurd that Esri could see that as a reasonable resolution.  It does nothing to solve the problem for organizations that have saved hundreds or thousands of MXDs pointing to an enterprise geodatabase.
0 Kudos
RobertBorchert
Frequent Contributor III
Once you get your MXD open and maplex turned off start a new arcgis session.

from the layout view copy all the elements.

paste them into the layout view of the new map.  not in the new data frame. you will create new data frames.

This is an old problem and I am surprised ESRI has not fixed it.  I have seen this same question a number of times for many months.

A lot of my maps were using the maplex extension for labelling.
We just upgraded to 10.1 and everytime I open a map that had maplex turned on the mxd crashes. 
If I get to the pause button ontime I can switch the properties back to the standard label engine, but it's getting rather frustrating.
Any fixes for this?
0 Kudos