Limited symbology in Map Viewer Beta

1490
20
Jump to solution
11-20-2019 06:04 AM
Katherine_Clark
MVP Regular Contributor

Hello,

I have been playing around with Map Viewer Beta this morning and noticed that there is very limited point symbology available. For instance, the "People Places" symbology list is gone, which our organization uses quite frequently.

I'd like to assume these limited options are simply because the Viewer is in Beta, but I wanted to confirm. Thanks! 

0 Kudos
20 Replies
Annina_Hirschi_Wyss
Occasional Contributor

Thanks, Russ. I just added you to the group. But if possible, do not share it any further, it's for the moment not designed for public use.

I tried it also with the AGOL early adopter version, the symbology classes are there, but "empty" and everything is packed under "other". I'll continue testing.

0 Kudos
Annina_Hirschi_Wyss
Occasional Contributor

I just tried the following in the beta viewer: when using the code ( eg. $feature["FIELD_NAME"]) instead of DomainName($feature,"FIELD_NAME") the symbol categories are created...

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Could you add the layer to the group as well. Thanks! 

0 Kudos
Annina_Hirschi_Wyss
Occasional Contributor

of course, sorry about that, it's done now.

RussellRoberts1
Esri Frequent Contributor

So to fix this can you declare your fields at the start of the expression:

$feature.CATEGORIE $feature["SYMBOL_ACCORD"] DomainName($feature,"CATEGORIE") + ", " + DomainName($feature,"SYMBOL_ACCORD")

best practice for this stuff is to be explicit with the fields because we optimize queries in 4x to only request fields we know about and we cant parse fields inside domain name etc.
Annina_Hirschi_Wyss
Occasional Contributor

Great, that seems to work. Just to know: Is it somehow possible to keep the symbology when changing the expression, but not modifying the display fields?

It would be awesome to be able to save the settings and apply them afterwards. But that's another issue :)

Anyways, thanks a lot for your availability!

Annina

0 Kudos
erica_tefft
Occasional Contributor III

I may just be dense, but I can't figure out how to adjust symbol sizes for anything other than the basic shapes (I am using symbols from the "Government" set)...is this the intention, or am I missing how to do that somewhere?

Any help would be awesome!

Erica
0 Kudos
RussellRoberts1
Esri Frequent Contributor

Do you see the size adjustment option with the symbol block expanded? The Symbol header can be minimized, if you click on the header this will expand the symbol block where you can pick the symbol and alter the size.

0 Kudos
erica_tefft
Occasional Contributor III

Hi Russell,

I do not...I am using Unique Symbols to symbolize my data by the "type" field within my data. I see the size option greyed out when I click on a value to assign a symbol -

Erica
0 Kudos
RussellRoberts1
Esri Frequent Contributor

Currently size is controlled at the top level through Symbol Style when using the Types Renderer