Does anyone know how to make the fields invisible in AppStudio?

168
5
09-01-2020 01:12 PM
New Contributor

A little background, 

      I have created a Citizen Report App. We were going to launch it before COVID but the City pushed the launch back to October. Last week, I was fixing some fields, that needed to be required.  I found out that you can delete the field in ArcPro in the table of the Main feature class and then re-add it through the configuration tool and make it non-nullible and required. If you use the same names then you don't have to fix any of the configuration.

   Unfortunately, I didn't know this was possible. So I tried overriding the feature class with a replicated feature class where the fields were fixed.  That broke everything. I have recreated everything. I even have the fields that I need required. 

   I haven't worked on this project so I can't remember how I got all the fields not to show up in the ArcStudio App. I already have most of the app set up in App studio. I just had to fix the map location and the layer location The rest is still in perfect condition except, I can't remember how to turn off the the extra fields. 

I know there is a way to do it but I don't remember how I did it last time. 

Can anyone point me in the right direction?

Tags (3)
Reply
0 Kudos
5 Replies
New Contributor

So I found this online that codes to remove the fields but I tried to use the code but the software isn't recognizing the field. I have tried shutting of the fields in the map that I directed the app to.  I have tried shutting the fields off in the the visible section of the feature layers settings and saved it. 

I used the code below in the Quick Reports qml, but none of it has work. 

fields from the rest

Reply
0 Kudos
Esri Regular Contributor

Hello, 

cc: ArcGIS AppStudio‌ for visibility. 

The ideal solution is to fix your feature layer, and if you have run the Quick Report template (your Citizen Report App) before, the app may have still cached the previous feature layer schema, so if you made changed to the feature layer schema after that, you need to call the Reset functionality in the Quick Report app. Top left hamburger menu -> Settings -> Reset.  See this post for more details, App Studio QuickReport Feature Layer modified 

You may also want to look at using Hosted Feature Layer Views of the original Feature Layer to hide some fields, see this post for more details, https://community.esri.com/thread/202869-hiding-fields-in-quick-report-template 

Thank you,

Erwin

Reply
0 Kudos
New Contributor

Never mind, It just magically starting working thanks!!!

Reply
0 Kudos
New Contributor

This was very helpful. Thanks. 

 My code was missing a " '' " so  so that is why it wasn't working.  I originally created a view layer and then clicked and unclicked the fields. I may try that way again. Right now. I am having trouble with getting the domains to come in as a drop down.  

I creating domain for the problem type, but it isn't coming in. I tried clearing the cashe already. For  some reason it works if I use a different view but just not this one. 

Reply
0 Kudos
Esri Regular Contributor

That's weird, the domain should work, is it possible for you to share the feature layer so that we can test? If not, we can probably troubleshoot this with Esri Technical Support‌. 

Reply
0 Kudos