COGO

312
7
Jump to solution
07-31-2019 05:55 AM
RawanAlhabbal
New Contributor II

Hello all!

After learning more about parcel fabric migration and administration I managed to migrate my parcels into Pro.  Everything worked fine but no COGO is showing for any of the tax line, record lines, or connection lines.  Does anyone have any explanation? 

Reply
0 Kudos
1 Solution

Accepted Solutions
RawanAlhabbal
New Contributor II

I think it was a bug or something. 

I left work after trying everything possible yesterday.  when I came to work today everything worked just fine.  COGO lines are calculated and everything else works just fine.  Thank you for your time and help.

Rawan. 

View solution in original post

Reply
0 Kudos
7 Replies
JasonCamerano
Esri Contributor

A few questions:

1. Did you migrate from existing feature classes?  Did you migrate lines as well and if so did they have COGO?

2. Was this an upgraded fabric?  If so what scale are you at, the COGO has a scale dependency on by default. 

If the lines don't have any COGO values, meaning you built the lines from the Polygon Geometry, you can run the Modify tool Update COGO.  Select all the lines and run the tool.  This will calculate all the COGO measurements from the geometry. 

RawanAlhabbal
New Contributor II

Thank you, Jason!

this is a screenshot of the data I used. I selected the Lines layer in our server database from my ArcMap fabric.  Maybe I should just run a query to select only tax parcel lines? 

Reply
0 Kudos
JasonCamerano
Esri Contributor

Can you check the attribute table of the Lines of the parcel type you're looking at?  See if there are COGO measurements

Reply
0 Kudos
RawanAlhabbal
New Contributor II

There are no COGO measurements.  No COGO Type, Accuracy or if it's ground or not. They're all NULL 

Reply
0 Kudos
JasonCamerano
Esri Contributor

That's really weird. Would you be able to get a subset copy of your ArcMap Parcel Fabric and send it to technical support so we can take a look at it?  This might be a bug, but without looking at the data I can't really tell.  Thanks!

Reply
0 Kudos
RawanAlhabbal
New Contributor II

I think it was a bug or something. 

I left work after trying everything possible yesterday.  when I came to work today everything worked just fine.  COGO lines are calculated and everything else works just fine.  Thank you for your time and help.

Rawan. 

View solution in original post

Reply
0 Kudos
AmirBar-Maor
Esri Regular Contributor

Rawan Alhabbal

We are happy that you managed to perform the data migration to the new fabric on your own and that everything works fine.

We do not populate the legal COGO dimensions on lines in the new parcel fabric.

If you do calculate them you also need to calculate the field COGOType to "From Geometry" so you will be able to know which measurements are inversed and which were entered from the legal documents.

We made a note that leaving work (sometimes) helps 😉