unable to add rasters to a mosaic dataset.

310
8
01-16-2020 07:51 AM
Highlighted
New Contributor

I'm using ArcMap 10.4.1, and have created the mosaic dataset, which shows up in the TOC as expected.

When I run the Add Rasters to Mosaic dataset tool, it stops after a few seconds with the error message "No mosaic dataset item selected." (screen shot attached).

I have lidar DEM tiles (1-m resolution) from a state website that were downloaded as .img files.  I've converted them to tiff and esri grid files, but the tool doesn't work with those either.

Do the raster files need to be in a different format?

Is there something preventing the mosaic dataset from being recognized?

thanks,

Reply
0 Kudos
8 Replies
Highlighted
Esri Esteemed Contributor

Hi Laura,

Can you zip and upload an image, or provide the URL from where you downloaded them from?

Also, what version of ArcGIS Desktop are you running?  Have you tried ArcGIS Pro?

Reply
0 Kudos
Highlighted
New Contributor

Hi,

I downloaded the lidar from the NH GIS website: http://www.granit.unh.edu/

I'm using ArcMap 10.4.1, but should probably upgrade.

thanks!

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Laura,

I'm assuming you downloaded some LAS files from the above site.  When working with LAS files, you'll need to know the average point spacing of the LAS files.  You can find this by executing the Point File Information tool.

It's best to have the cell size 3-4 times the avg. point spacing.  Then, following the steps in the below link on how to add the lidar data to a mosaic dataset:

Adding lidar data to a mosaic dataset—Help | ArcGIS Desktop 

The key is to specify LAS for the Raster Type.  You will then need to click the icon to the right of this to specify the cell size:

You should then see the lidar within the mosaic dataset:

Reply
0 Kudos
Highlighted
New Contributor

Hi,

Thanks for the email...I've actually been using hydro-flattened DEM tiles,

which I guess are not useable.

I'll try to get the LAS data and go from there.

thanks again,

Laura Deming

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Laura

I would not advise you revert back to the LAS files unless you have a need for 3D analysis or creating your own DEMs (bare earth DTM or first return DSM).  I don't think Jake was suggesting that, but he was trying to clarify which files you had downloaded.

Using the hydro conditioned DEM in *.img format (or *.tiff format if you choose to convert) should be the best approach.  You are running into some simple problem that we need to figure out.


Can you send just 2 or 3 adjacent tiles for us to test with?  I'll send you a direct message

Cody B

Highlighted
New Contributor

Hi,

Here are 3 tiles and the error message, which seems to show that the tiles

are recognized.

thanks so much!

L_0915004300_16.img

<https://drive.google.com/a/antioch.edu/file/d/1ClIA6SqWqNAQTvrOpJ4tZlvL7om0Fab-/view?usp=drive_web>

L_0915004250_16.img

<https://drive.google.com/a/antioch.edu/file/d/1MpIhNUn79WsPuo9k93eHdK7k8ObJIdmL/view?usp=drive_web>

L_0915004350_16.img

<https://drive.google.com/a/antioch.edu/file/d/1ipkWl0sKocjXZfYLrmsK9K2S66zMSTRS/view?usp=drive_web>

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Laura

this works fine for me, as I expected it would.  I'm using ArcGIS Pro 2.4, and also tested with ArcMap 10.7.1.  Dialogue below from ArcMap.  

I'm (almost) certain it's not a bug in 10.4.1.  What you're trying to do is VERY much 'plain vanilla mosaic dataset' (as far back as version 10.0) so something unexpected is causing this.  Did you see my direct message?  I'd like to confirm your exact steps.  Are you creating a new file GDB, and a new mosaic dataset?  Are you using GP tools or context menus in the GUI?  If you drag and drop the individual tiles into the map do they appear w/o problems?  (It will likely ask you to build pyramids)

Cody B

Reply
0 Kudos
Highlighted
New Contributor

Hi,

these are the steps:

1. create new geodatabase (in Arc catalogue)

2. create new mosaic dataset (in Arc toolbox)

3. add rasters to mosaic dataset (in Arc toolbox) - this runs for 5-6

seconds before shutting down with the error message that no mosaic dataset

has been selected. I've tried to create the mosaic dataset several times,

but get the same result.

I chose Raster Dataset as the raster type.

I can rerun these steps and send screen shots if that would be helpful.

thank you so much!

Laura

Reply
0 Kudos