Trouble Importing Rasters/Tables

11-06-2020 05:15 PM
New Contributor

I am having trouble importing into a file GDB in ArcCatalog (10.3) all of a sudden.  With rasters I get a message 'No spatial reference found', even though the rasters 'do' contain spatial reference. And when I import tables, they import but are blank (fields only). 

Any ideas what's happening here?  Everything was working fine the past few years.....

0 Kudos
1 Reply
Esri Contributor


You mention no issues importing rasters previously. I'm just curious to know if you are able to perform some tests to isolate a possible issue. Sorry if all these questions sound trivial.

Have you tried importing a few of the rasters which you say worked previously into a new file GDB with no issues? i.e. if they imported previously with no issue but give you trouble now then perhaps it's not your data.

Is there a difference in the spatial reference definitions between the rasters you are trying to import and the ones that did import successfully?

Also, have you tried the operations you are trying to accomplish in a clean (new) file GDB?

Is this on a drive that catalog has full access or has something changed in the system between when this worked and currently?

Were the rasters exported from software that has different methods of defining projections? (incidentally, do the rasters display correctly in ArcMap and in the right 'spot' with no issues in their projection definition? I have encountered this issue previously wherein the projection defined wasn't recognized.

You haven't mentioned if you are using a mosaic dataset. As a side-note, this is a really good way to organize your raster data and with which you may take advantage of tools to mosaic multiple rasters into one, or apply raster functions in one place. I mention this because you can 'define' the projection of your source rasters in the mosaic dataset before adding them to the mosaic dataset - even if the projection is unrecognizable or 'non-standard'.


Tags (2)