Tiff Raster- Colour outside of ArcGIS, Black White in ArcGIS

3229
2
Jump to solution
06-14-2017 04:31 AM
GavinCollins
New Contributor

I have extracted a subsection of a large raster. The file displays in full colour outside of ArcGIS but when imported into ArcMap or Pro it display as black and white despite being set to display in colour/all bands.

Tried rerunning calculation of its statistics in Catalog so far.

Thanks

Gavin

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
GünterDörffel
Occasional Contributor III

Hi,
the file is just fine 🙂 But you should recreate the overviews - they seem to be corrupt - and make sure the file is interpreted as "processed" and not stretched when loaded:

So proceed like this:

Go to the folder you stored the data in and delete the *.ovr file

In Catalog /(or Folder view in Pro) open the properties of the dataset and define the source type as "Processed".

In Catalog /(or Folder view in Pro) open the properties of the dataset and REMOVE the NOData value (set to 255,255,255) to be empty.

Now right-click the image again and create new Pyramids - Nearest Neighbor/LZ77 works fine for this data
When adding it to the display now, everything should be fine and since you did Nearest/LZ77 you can still set 255,255,255 background color to be transparent (in the Symbology of the layer) and it will look fine on all levels. I attached the result

Regards
Guenter

View solution in original post

0 Kudos
2 Replies
GünterDörffel
Occasional Contributor III

Hi,
the file is just fine 🙂 But you should recreate the overviews - they seem to be corrupt - and make sure the file is interpreted as "processed" and not stretched when loaded:

So proceed like this:

Go to the folder you stored the data in and delete the *.ovr file

In Catalog /(or Folder view in Pro) open the properties of the dataset and define the source type as "Processed".

In Catalog /(or Folder view in Pro) open the properties of the dataset and REMOVE the NOData value (set to 255,255,255) to be empty.

Now right-click the image again and create new Pyramids - Nearest Neighbor/LZ77 works fine for this data
When adding it to the display now, everything should be fine and since you did Nearest/LZ77 you can still set 255,255,255 background color to be transparent (in the Symbology of the layer) and it will look fine on all levels. I attached the result

Regards
Guenter

View solution in original post

0 Kudos
SteveMurphy
New Contributor II

I've been having the same problem: Raster images display B&W in ArcMap when they are in fact color.

The solution was Guenter's first one: stretching. Go into Layer Properties>Symbology. Select RGB Composite. Duh you knew all that, why is it still B&W? There is a second place where stretching is applied. Under RGB, set Stretch type equal to none and uncheck 'Apply gamma Stretch'. Not exactly hidden but not immediately obvious. 

(I am on 10.2.2)

Layer Properties Dialog

0 Kudos