"Caught unknown exception during initial processing" error

960
5
10-11-2018 05:56 AM
Labels (1)
ViTran
by
New Contributor II

Hi,

I'm running a project in Drone2Map using 43 nadir images on an area of 3.14 acres. I have 4 GCPs in this project. However, whenever I tried to include the GCPs in the processing, this error comes up: "Caught unknown exception during initial process".

I tried to run the project with just the images. That resulted in 2D products and 3D point cloud (per my Processing options). However, I can't use these products because they are way off. I was hoping to use the GCPs to improve the accuracy of my project. I'm attaching here the end of the project log. I'm not sure what causes this error.

0 Kudos
5 Replies
MichaelRawitch1
New Contributor III

Was there ever a resolution to this issue? 

0 Kudos
CodyBenkelman
Esri Regular Contributor

Sorry, I never saw this post.  This is saying there is no problem with processing if GCPs are not applied, but adding GCPs creates the error?  I'd have to know more about the GCPs.  Were they from a GPS unit (imported as text) or extracted ad hoc from the imagery basemap?  Can you share the GCPs, or at least a description of how they were entered, which coordinate system they were in, the vertical datum, etc.?

Cody B

MichaelRawitch1
New Contributor III

Cody, 

No problem, and thank you for responding. I have not tried removing the GCPs yet, but am receiving the same error and log. The GCPs I am using were collected using an EOS Arrow Gold and Collector, and then tagged in Drone2Map manually (5 tagged photos each). I believe the coordinate system is WGS84, and the vertical datum is GEOID 96. I am using Drone2Map version 1.3.2.232 on a VM with plenty of computing power. I have also processed with Drone2Map successfully on this machine in the recent past. The imagery data was collected with a DJI Matrice 210 and a Zenmuse X5S camera. 

Thank you in advance for any help you can provide. 

Sincerely, 
Mike R

0 Kudos
SuzanneWade3
New Contributor III

Hi Cody,

I am also having this problem with GCPs causing the same unknown exception message.  When I take them out it processes fine.  They were also collected with an EOS Arrow Gold and Collector.

Thank you,

Suzanne

0 Kudos
JamesVogl
New Contributor II

This is apparently a recurring problem when processing using ground control points. Removing GCPs eliminates the error. Points were collected with Trimble R1 and AGS collector and imported into Drone2Map from csv via a downloaded ground control points Control' hosted Feature Layer created from a template in AGOL. Thank you for any insights.

UPDATE: ESRI just released D2M major revision 2.0 at the end of June. After instaling the update I was able to process the project successfully. Be sure that ALL of the GCPs in the table reside within the extent of the current project.