Point cloud / mesh beneath ground elevation and basemap

670
10
07-10-2019 12:08 PM
Labels (1)
Highlighted
by
Occasional Contributor III

I just generated a 3D point cloud / mesh and in Drone2Map and Pro it is beneath the ground elevation and basemap. What is going on here?

Reply
0 Kudos
10 Replies
Highlighted
Occasional Contributor

Ian, 

This happens when the altitude values from the drone are not accurate and/or ground control was not used. If you are not using ground control, use the Image Altitude tool on the Flight Data tab.

https://doc.arcgis.com/en/drone2map/help/flight-data-geolocation.htm#ESRI_SECTION1_5A127E05AEE24073A...

Additionally when you create a 3D point cloud / mesh in D2M, you can also create a DSM and DTM. You can then add one of these (DTM is best) as a ground elevation source in ArcGIS Pro. This will set the elevation in your project area to what was processed in D2M. 

Thanks

Tony

Reply
0 Kudos
Highlighted
New Contributor II

Anthony,

I have the same problem with processed outputs being produced below ground, and nothing about the EXIF data suggests that there is a problem with the photo heights.

Photo heights are all ~ 240m.  Terrain is flat and an independent DEM for the area covering the drone project area shows an MSL of ~ 130 m.  DJI P4 RTK drone flying height was 110 m.  Everything adds up.

And yet:
2.  The DTM is output with values ranging from minus 208 m to minus 191 m
3.  The DSM is output with values ranging from minus 208 m to minus 138 m

The solution proposed above wont work if the DSM itself is also produced at below ground (which it is).

I am fairly convinced this is an issue with the software.  The same photo set uploaded to DroneDeploy processes correctly without any modification to the heights, as it should, because they are correct.

In Drone2Map I have also experienced other projects with the same negative height issue, flown next to others that are processed correctly.  There is apparently no logic to why this happens sometimes.

I have lodged a case with a link to download the photos, in the hope that someone can process the project and experience the same issue:  

Highlighted
Occasional Contributor

Gregor,

What vertical reference are you using? For the DJI P4 RTK drone we recommend using the vertical reference: Height Above Ellipsoid and leaving the Geoid Height at 0. 

Set this for both Image Coordinate System and Project Coordinate System through Options > Coordinate Systems.

Can you give this a try and see if it helps?

If you have already tried this we can get our support team involved to collect more information to help figure this out. 

Thanks,

Tony

Reply
0 Kudos
Highlighted
New Contributor II

Hi Tony,

Thanks for the suggestion.  However, no change.  Previously I had EGM96 set as the vertical reference for both image and project.

Highlighted
New Contributor II

Solution to this issue from ESRI:

  1. Create a new project
  2. I choose the following processing options: Under initial: Rapid (you can use full), Aerial Grid or Corridor, Make sure you change the Calibration Method to Geolocation and Orientation.
  3. Everything else is default. Click apply and ok
  4. Now save and close the project.
  5. ** Browse to C:\Users\USERNAME\Documents\Drone2Map\Projects\PROJECTNAME\Project\Data and right click and edit the processing_options file in notepad
  6. Change <internalParamOptimization>All</internalParamOptimization> to <internalParamOptimization>AllPrior</internalParamOptimization> and save the file
  7. Reopen the D2M Project and Run the process
  8. The output should be on the ground

** If the settings are saved as a template for future projects, do this instead:  unzip the saved template and edit the file engine_settings  

Reply
0 Kudos
Highlighted
New Contributor

Hi Gregor, 

I just tried this solution and does not work for the mesh nor the point cloud. Both float way above.

I used these coord systems: image: GCS WGS 1984, EGM96 and for Project: WGS 1984 UTM Zone 31N, EGM96.

(1) Should I be using Above Ellipsoid and leaving the Geoid Height at 0?? 

(2) I am not using a local terrain file just the defaults. I am looking for one to use, but the instructions above do not mention this. Should I also be using one?

(3) Images are from DGI Mavic with altitudes in centimeters how do I fix this with D2M?

(4) Further, I have all project units set to meters, but when I mouse over they display feet units are displayed. I cleared the cache but no change. 

Please let me know what you recommend for the 4 items above. Thanks,

L.

Reply
0 Kudos
Highlighted
by
Occasional Contributor III

//

Reply
0 Kudos
Highlighted
New Contributor

Hi Ian, Thanks for your reply. Yeah I figured that much. it would be nice to have the option to purchase Pix4D. Maybe in the future.  I figured out  questions 2 to 4 but not the first one... guess trial an error will rule.

PS. Editing the project file does seem to help in getting better meshes. 

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Lessie

You don't mention ground control.  Are you using it?  Without control, the output products shouldn't be expected to correlate to the actual earth (in xy position and scale for the orthomosaic, or the xyz position for 3D products).  True, the GPS alone can get you CLOSE, so a project flown in Namibia shouldn't appear to be in Venezuela, but for greater accuracy, 3D ground control is absolutely required.

You can extract control from our imagery basemap, and that will include a Z value from our worldwide terrain.  Note of caution, there are SOME areas where the image or terrain  accuracy are not high, so if you get a strange result you may need to move one or more control points - but if you're not using control, please try that and let us know if this fixes your issue.  It's really a very easy step...


Cody B  

Reply
0 Kudos