Mosaic Dataset footprints and boundaries

843
4
Jump to solution
01-23-2019 06:49 AM
BenasPekarskis1
New Contributor II

I have around 700 images of Areal photography. Images are compressed in  JPEG format. When I load all images in Mosaic Data set, they align very well. By align I mean there are no gaps in between images. See pic:

But when I build footprints and boundaries for the same Mosaic data set, it builds boundary with gaps between images. See picture: 

And when I set Mosaic Data set properties to "Always Clip The Rasters to Its Boundary", it clips the  some images and leaves the Gap in between. See Picture:

My question is:

Is there are workflow I should follow to build footprints and boundaries so it excluded NoData values, but would not build artifacts in between some pictures? 

If you require more clarification, please let me know and I will post my full workflow. 

Reply
0 Kudos
1 Solution

Accepted Solutions
PeterBecker
Esri Regular Contributor

The build footprint by Radiometry option attempts to determine the visible extent of the image by creating a mask of the data and then creating a contour polygon around the data. Instead of doing at full resolution, by default it samples the image first. If you look at the parameters of the tool you will see a 'request size' parameters. I suggest you increase this size. Also in your case as the images are edge joined turn on the 'maintain sheet edges' parameter. This will try and maintain the vertical and horizontal edges better.

In the way you are using the mosaic dataset currently each raster is a separate item, although in this case you have a collection of pre-mosaicked and then re-tiled images. Look at the 'Merge' tool.  Merge Mosaic Dataset Items—Data Management toolbox | ArcGIS Desktop . You should be able to merge together collections of images that are a group.

The third option is to turn off the clip by footprint parameter

Fourth option: If you have a geometry that defines the extents of you imagery (could be a project boundary to which the original imagery was clipped) then use the clip tool on the footprint to clip the original (or build footprints by geometry) footrpints to this boundary.

View solution in original post

4 Replies
PeterBecker
Esri Regular Contributor

The build footprint by Radiometry option attempts to determine the visible extent of the image by creating a mask of the data and then creating a contour polygon around the data. Instead of doing at full resolution, by default it samples the image first. If you look at the parameters of the tool you will see a 'request size' parameters. I suggest you increase this size. Also in your case as the images are edge joined turn on the 'maintain sheet edges' parameter. This will try and maintain the vertical and horizontal edges better.

In the way you are using the mosaic dataset currently each raster is a separate item, although in this case you have a collection of pre-mosaicked and then re-tiled images. Look at the 'Merge' tool.  Merge Mosaic Dataset Items—Data Management toolbox | ArcGIS Desktop . You should be able to merge together collections of images that are a group.

The third option is to turn off the clip by footprint parameter

Fourth option: If you have a geometry that defines the extents of you imagery (could be a project boundary to which the original imagery was clipped) then use the clip tool on the footprint to clip the original (or build footprints by geometry) footrpints to this boundary.

View solution in original post

BenasPekarskis1
New Contributor II

Thank you very much. 

I will try your suggestions and  come back with the results. 

Regards,

Ben

Reply
0 Kudos
BenasPekarskis1
New Contributor II

Peter,

Thank you.  I have used properties within Mosaic Dataset "Always Clip to Boundary" and it worked for time being. 

Reply
0 Kudos
HeatherKelley1
New Contributor

What is the value range on the Request Size option? What is a reasonable value to go up to?

I'm at 12,000 and still have white gap areas appearing along vertical boundaries. The angled boundary has improved and no longer has a white gap.

Reply
0 Kudos