Modify mosaic dataset 'NoData' black background

1265
4
Jump to solution
03-11-2019 03:43 PM
SamyBouma_Ngock
New Contributor

Hi,

Problem:

I used to build mosaic datasets (MDs) in Desktop 10.3 and have the NoData background managed as transparent by/within the MD.

I recently upgraded to 10.6 and all the MDs have now the NoData background blackened.

Action:

- reprocessed the MDs using arctoolbox MD tools (i.e. build footprints, calculate statistics, etc.): failed

- recreated a new MD with original images and properties definition: failed

- did a bit of search online, but not conclusive as why although it is my understanding that a mask is usually created with the MD to manage NoData value

- Most of accessible info point to how to symbolize raster nodata/background value which does not help my case since Symbology>Display Background Value>Display NoData as 'No Color' leaves boundary pixels visible...

Questions:

Is this a bug in 10.6?

If not a bug, is the MD imagery workflow different in 10.6 than in 10.3?

How to get the background transparent again from within the MD for my map products?

Thank you

Samy

0 Kudos
1 Solution

Accepted Solutions
GuenterDoerffel
Esri Contributor

Hi Samy,

there was a known issue with JPEG-compressed image display and NoData. A Patch for 10.6.1 (hope this is what you installed?) was released to solve that:

See here: Esri Support ArcMap 10.6 (10.6.1) 


You should use 10.6.1 anyway. And if you dont have the option to use 10.6.1, changing the display setting for the data from jpeg-compressed to lets say LZW will also solve the issue.

Regards
Guenter

View solution in original post

4 Replies
DanPatterson_Retired
MVP Esteemed Contributor
0 Kudos
SamyBouma_Ngock
New Contributor

Thanks for you assistance Dan. 

0 Kudos
GuenterDoerffel
Esri Contributor

Hi Samy,

there was a known issue with JPEG-compressed image display and NoData. A Patch for 10.6.1 (hope this is what you installed?) was released to solve that:

See here: Esri Support ArcMap 10.6 (10.6.1) 


You should use 10.6.1 anyway. And if you dont have the option to use 10.6.1, changing the display setting for the data from jpeg-compressed to lets say LZW will also solve the issue.

Regards
Guenter

View solution in original post

SamyBouma_Ngock
New Contributor

Right on Guenter.

I did install 10.6.1 but seemingly missing the JPEG NoData patch.

In the meantime, I use LZ77 or LERC compression method to get the NoData background transparent.

Thanks

Samy

0 Kudos