georeferenced raster aerial

330
1
10-17-2020 07:31 AM
NancyScott
New Contributor

Hello:

After georeferencing the raster images below, they have a gap between them. Does anyone know how to fix this? You can see that the building shapefile lines up with the aerial so it it appears that I georeferenced them correctly. geo-reference# #image display properties

0 Kudos
1 Reply
PeterBecker
Esri Regular Contributor

By the look of it: you have georeferenced imagery that originally had a black frame. In the georeferencing the pure black was identified as NoData and turned to white. There are though other pixels that were not pure black and so there remain as the black artifacts at the edges. In the image white is not defined as no data so when you overlay one image on the other you are seeing the extent of the overlapping image. I assume if you change the image order the gap will move but still be there. Turning pixels to NoData will not help due to the artifacts.

If you only have a couple of images then do the following: Create a feature class (polygon), Start editing and draw a polygon that is just within the extent of useful pixels. Repeat for second image. Select the record for the first image. In Imagery,raster functions, open the Clip raster function. Select the 1st raster, Clipping type:Outside, Clipping geometery: (select the feature class with selected record). Create New Layer. This should result in an layer with the outside clipped out. Repeat for the second image and then use the mosaic function to mosaic both together.

The other way to do this is to create a mosaic dataset, add the rasters, then use recompute footprint by radiometry with say 80 vertices and suitable buffer (I'm guessing 20m). This will automatically clip the images based on the footprint, which you can also edit if needed. 

0 Kudos