custom transformation not functional mosaic dataset

729
4
Jump to solution
03-25-2018 06:39 AM
larryzhang
Regular Contributor

Hello,

Recently practice and witness the following, which is reproducible in ArcGIS 10.4.1 and 10.5.1:

Background: 

  • ArcGIS built-in (3 to 5-parameter) transformation between WGS84 and local datum, called 'Option 1' used by default in Mosaic Dataset;
  • A more accurate (7-parameter) custom transform between WGS84 and local datum, called 'Option 2', which is used to take over Option 1 in Mosaic Dataset

Action:

  • Option 2 is customized, which is also configured via Environment Settings (for takeover of Option 1), where NADCON file is managed under C or D:\Program Files (x86)\ArcGIS\Desktop10.5\pedata\nadcon folder

Symptom:

  • When images with WGS84 (UTM) are loaded into a Mosaic Dataset (with local datum), the Option 2 is not functional, which still uses Option 1 for the transformation. It looks no takeover at all.
  • However, if those images are directly loaded into ArcMap, it demonstrates two options: Option 1 and Option 2. When the Option 2 is selected, the transformation works fine. 

Any advice?

Regards,

0 Kudos
1 Solution

Accepted Solutions
larryzhang
Regular Contributor

thx, Xu,

Eventually, the issue is identified and fixed in mosaic dataset:

In addition to two local datum files (.las, .los) to be placed in 'C or D:\Program Files\ArcGIS\Pro\Resources\pedata\nadcon', the third file (.GTF), which is referred to 'GRID Transform File', is also required and copied to the user’s Application Data folder, in the ESRI Custom Transform directory as follows, saying hlzhang525:

C:\Users\hlzhang525\AppData\Roaming\ESRI\Desktop10.5\ArcToolbox\CustomTransformations

Similarly, to do same in image server, if this local transformation is applied to image services or dynamic caching ..

Regards,

ZHANGH @ ARAMCO

View solution in original post

0 Kudos
4 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Larry... 'loaded into a mosaic data set'... 

how exactly, since supported environment parameters are listed with tools 

  (ie http://pro.arcgis.com/en/pro-app/tool-reference/data-management/add-rasters-to-mosaic-dataset.htm)

and general parameters may or may not be supported

0 Kudos
AbdullahAnter
Regular Contributor II

I will mention this to Coordinate Reference Systems and Melita Kennedy .

0 Kudos
HongXu
by Esri Contributor
Esri Contributor

Hi Larry,

Without knowing the detail of your local datum, I tried using this case:  UTM (WGS84 datum) as the projection of the mosaic dataset and NAD27 and NAD83 as datum for the images that will be loaded to the mosaic dataset.

   1. create a mosaic dataset with UTM projection and add datum transformations from the GP environment setting for transformation between WGS84 and NAD27 and WGS84 and NAD83, there are many options that are available, but make sure that you pick one that is suitable for your data

   2. add the images to the mosaic dataset. This should be done. when accessing the mosaic dataset (the images in the mosaic dataset), the system will pick the corresponding transformation to use.

when you comparing with ArccMap, please make sure that they are using the same transformation (ArcMap default may not be the one that you pick from the environment setting). If you still see issue or issue with your data, please contact Esri support with your data to reproduce.

Regards,

Hong Xu

larryzhang
Regular Contributor

thx, Xu,

Eventually, the issue is identified and fixed in mosaic dataset:

In addition to two local datum files (.las, .los) to be placed in 'C or D:\Program Files\ArcGIS\Pro\Resources\pedata\nadcon', the third file (.GTF), which is referred to 'GRID Transform File', is also required and copied to the user’s Application Data folder, in the ESRI Custom Transform directory as follows, saying hlzhang525:

C:\Users\hlzhang525\AppData\Roaming\ESRI\Desktop10.5\ArcToolbox\CustomTransformations

Similarly, to do same in image server, if this local transformation is applied to image services or dynamic caching ..

Regards,

ZHANGH @ ARAMCO

View solution in original post

0 Kudos