Classify Pixels Deep Learning Package results checkerboard?

570
13
Jump to solution
05-05-2021 04:50 PM
KathleenHoenke
New Contributor III

I'm trying to use the road extractor model within the Classify Pixels Using Deep Learning tool. I believe I've installed the tools for deep learning correctly, I ran the tool going step by step with the tutorial, and my output is literally a black and white checkerboard. Is this indicative of a particular error? 

0 Kudos
1 Solution

Accepted Solutions
VinayViswambharan
Esri Contributor

The M2000M is a low end GPU. I would recommend switching to a higher end GPU. 

You mentioned you got an error message ArcMap stopped working. These tools dont run in ArcMap. Only works in ArcGIS Pro. CPU is extremely slow in these cases, so it will take a long time (especially at that resolution). ensure you set your batch size to 1 (or max 2), if not - you will run out of memory. zoom into a scale of 1:3000 maybe and then force your resolution to maybe 30 cms (to just test) 

 

 

View solution in original post

0 Kudos
13 Replies
DanPatterson
MVP Honored Contributor

You are lucky you got a checkerboard... some people only got a white screen 😉

Classify pixels using deep learning -- results not... - Esri Community

To the immediate right of your post are a bunch of related links.  Problems abound with the deep learning tools.  Some are related to installation, some to data issues and some are just issues.  


... sort of retired...
0 Kudos
KathleenHoenke
New Contributor III

LOL! I’ll take any small win! Is there a way to check that it installed correctly? 

0 Kudos
DanPatterson
MVP Honored Contributor

Kathleen, the frameworks are available here with its documentation

Esri/deep-learning-frameworks: Installation support for Deep Learning Frameworks for the ArcGIS Syst...


... sort of retired...
0 Kudos
VinayViswambharan
Esri Contributor

@DanPatterson - the issue was resolved over a quick call. The user had created a 32bit raster and the "Export training data" output was not tiff, which collapsed the number of bands. In fact we built an RFT that prepared all her images to automatically remove clouds based on the QA band and then perform deep learning on a stack of images. She will be posting a summary of our call on that thread.  

0 Kudos
DanPatterson
MVP Honored Contributor

Hopefully it gets documented in the help files somewhere as a symptom of a procedural issue.

The installation query was then apparently ruled out


... sort of retired...
0 Kudos
VinayViswambharan
Esri Contributor

Hi Kathleen - we've seen this happen when running the processing on an unsupported GPU. So I've got a few questions:

1. Are you using GPU or CPU to perform inferencing?

2. If GPU, which GPU?

3. Can you try this using your CPU (specify it in the enviornment settings), it will be a lot slower, so pick a small area to test.

4. What are the image properties of your input? (resolution, num bands, bit depth, source)

0 Kudos
KathleenHoenke
New Contributor III

Hello and thank you! I was trying to use the GPU. Here is the information about my GPU. Could you tell me if this GPU is adequate? I tired the CPU and it didn't even try to run, just threw the arcmap stopped working image! My image is a 0.5 ft resolution 3 band 16 bit, source is NC one map North Carolina. While it's only a small piece of a HUC12, looks like uncompressed size is 49 gb....

 

KathleenHoenke_0-1620304225910.png

 

0 Kudos
VinayViswambharan
Esri Contributor

The M2000M is a low end GPU. I would recommend switching to a higher end GPU. 

You mentioned you got an error message ArcMap stopped working. These tools dont run in ArcMap. Only works in ArcGIS Pro. CPU is extremely slow in these cases, so it will take a long time (especially at that resolution). ensure you set your batch size to 1 (or max 2), if not - you will run out of memory. zoom into a scale of 1:3000 maybe and then force your resolution to maybe 30 cms (to just test) 

 

 

View solution in original post

0 Kudos
KathleenHoenke
New Contributor III

Sorry, I am running the latest version of pro, I misspoke. I see I have two GPUs. I apologize, I’m not super computer savvy. Is the other one better and can I switch between the two, or is there a way to purchase and add one to a current pc? 

 

Thank you!

0 Kudos