Can't start Image Service

2661
4
08-22-2011 05:17 AM
ShaningYu
Frequent Contributor
I tried to create an Image Service and then started.  I got the the problem to start it.  My procedure is below and the

1) Start ArcCatalog and navigate to the Image layer in the SDE Geodatabase.
2) Right-click the image layer and then click Publish to ArcGIS Server.
3) When the wizard pops out, select the folder created (e.g. Wildlife_Images), and then click Next button.

4) On the next page of the wizard, only Image is checked.  Click Next button.

5) Click Finish button.
Then, I received the warning message (see the attachment)

6) Open the ArcGIS Server tree on the Catalog, I could see the image layer in the Wildlife_Images folder.
7) Right-click the image layer and then click Start, the same message shows the failure of the Start.

What is wrong with my procedure here?  If you know, please provide help.  Thanks.
Reply
0 Kudos
4 Replies
RobertBerger
New Contributor III
Greetings,

So you are trying to start an image service out of a SDE database? And just to be clear, you are trying to use a single dataset to serve out, not the image extension?
In that case, what I have seen previously, is that somehow you need to teach the server how to connect to SDE. I've saved the sde connection file and moved it to a place that the server can access. Then I connect to the dataset through that connection file. So, for example, the path for the server is \\mymachine\data\connection.sde\rasterdataset.
I hope this helps.

Robert
Reply
0 Kudos
ShaningYu
Frequent Contributor
Robert:
Thanks for your post.  However, I could not understand well your post.  I created the service, which means that the connection to SDE is OK.  I tried to start it either in Catalog or ArcGIS Manager, but got failure in either scenario.  The message below is from ArcGIS Server Manager when I tried to Start:
Unable to Start service. Error (Configuration Wildlife_Images/ORC.ORCWILDLIFE.CDL_1999.ImageServer can not be started. Server Object instance creation failed on machine d422453603. ).
Reply
0 Kudos
PatrickWard1
New Contributor II
Shaning,

Make sure the ArcGISSOC user account has read access to the SDE Geodatabase that the image layer resides in. If the ArcGISSOC user account does not have read permissions then the Image Service will not be able to start.

http://help.arcgis.com/en/arcgisserver/10.0/help/arcgis_server_dotnet_help/index.html#//00930000005v...
Reply
0 Kudos
JeffreySwain
Regular Contributor
Also depending on the connection to the SDE, the SOC user may need to be added to the database in order for it to have access.   Per the help that Patrick recommended,
If you're working with an ArcSDE geodatabase at the Enterprise level, the way that you add the SOC account as a valid user of the database varies depending on the DBMS that you are using. You may find it helpful to consult your DBMS documentation to learn how to grant access to an operating system account. Once you've added the SOC account, you need to grant it SELECT permissions to the resource that you are going to publish. Additional permissions may be necessary if you will be editing data.
Reply
0 Kudos