Assisted Links Error

02-12-2020 10:49 AM
Labels (1)
Occasional Contributor

I am testing the new Assisted image links feature and after adding the first link, it seems D2M is not estimating the location of image links for the remaining images.  I am not seeing the crosshair icon or the circle icon in the image list.  I've gone through the documented workflow a few times, but still no dice.  I've included below the logging from the point I add the control point to the map and use the Image Link Editor to create a link on the first image in the list:

2020-02-12 11:36:43,939 DEBUG - Drone project SetProjectCoordinateSystem
2020-02-12 11:36:43,942 DEBUG - Completed:  SetProjectCoordinateSystem
2020-02-12 11:36:43,988 DEBUG - SpatialReferenceJsonConverter:WriteJson Write SR Json: {"wkid":32613,"latestWkid":32613,"vcsWkid":5773,"latestVcsWkid":5773}
2020-02-12 11:36:43,989 DEBUG - SpatialReferenceJsonConverter:WriteJson Write SR Json: {"wkid":32613,"latestWkid":32613,"vcsWkid":5773,"latestVcsWkid":5773}
2020-02-12 11:36:43,990 DEBUG - ApplicationStateUtils:SetState Activating State: esri_drone2map_ProjectHasControlPointState
2020-02-12 11:36:43,991 DEBUG - Caught HandleGroundControlPointCollectionChanged in ControlPointService
2020-02-12 11:36:43,991 INFO  - DeactivateAsync Setting Pan
2020-02-12 11:37:31,602 DEBUG - LayerDataSourceCache:GetLayerForFeatureClass Searching for layer with data source: E:\Drone_Projects\treeder_UAV_StateLine\Segment10\StateLine_segment10\StateLine_segment10.gdb\Control
2020-02-12 11:37:31,603 DEBUG - LayerDataSourceCache:GetLayerForFeatureClass Found layer with uri CIMPATH=2d_map/control.xml for feature class E:\Drone_Projects\treeder_UAV_StateLine\Segment10\StateLine_segment10\StateLine_segment10.gdb\Control
2020-02-12 11:37:31,993 INFO  - ImageUtils:SortImagesByDistance Sorting images by distance took 161 ms
2020-02-12 11:37:32,016 INFO  - Setting image link to DJI_0075.JPG
2020-02-12 11:38:00,299 DEBUG - SpatialReferenceJsonConverter:WriteJson Write SR Json: {"wkid":32613,"latestWkid":32613,"vcsWkid":5773,"latestVcsWkid":5773}
2020-02-12 11:38:00,301 DEBUG - SpatialReferenceJsonConverter:WriteJson Write SR Json: {"wkid":32613,"latestWkid":32613,"vcsWkid":5773,"latestVcsWkid":5773}
2020-02-12 11:38:00,714 ERROR - ControlPointService:GenerateControlPointEstimates System.ArgumentException: Value does not fall within the expected range.
   at ServiceContracts.IDrone2MapService.GetInfoForPixelCoordinates(String mdPath, String imageName, String geometryXml)
   at ArcGIS.Desktop.Drone2Map.ControlPoints.Utils.ControlPointService.<GenerateControlPointEstimates>d__40.MoveNext()

I ran Initial processing selecting only the Initial processing step and keeping the Keypoints Image Scale at Full.  am not sure where to go from here.  Please let me know what other information would help with the troubleshooting.

Thanks for your help!

Tags (1)
0 Kudos
1 Reply
Occasional Contributor

Never mind.  I ran through the workflow again on a new project and everything worked as advertised.  Now I just need to go back to the initial project to see what was going on.

0 Kudos