Adding a field to an existing Image Service

252
3
Jump to solution
06-04-2018 10:36 AM
AlexGerrish1
New Contributor III

I'm trying to add a date field to a time-enabled master image service and I can't get changes I make to the mosaic dataset to reflect in the image service that references it. As the data owner should I be able to make schema changes to the image service? Do I have to republish?

I'm working in an ArcGIS Enterprise 10.5.1 environment with my source mosaic datasets referenced by my Image Server. Stopping the service and adding the fields doesn't seem to work.

0 Kudos
1 Solution

Accepted Solutions
CodyBenkelman
Esri Regular Contributor

Alex

Stop the service, edit the MD to add the new field, then restart the service. 

My guess is this is all working, but you also need to edit the Service Properties --> catalog --> allowed fields to enable access to the new field.  By default it will be off.

View solution in original post

0 Kudos
3 Replies
CodyBenkelman
Esri Regular Contributor

Alex

Stop the service, edit the MD to add the new field, then restart the service. 

My guess is this is all working, but you also need to edit the Service Properties --> catalog --> allowed fields to enable access to the new field.  By default it will be off.

View solution in original post

0 Kudos
AlexGerrish1
New Contributor III

That works excellently! I checked the new field under Catalog parameters in the MD and the Image Service(s).

Thank you, Cody.

0 Kudos
HayleighPervorse2
New Contributor III

Hi, 

I have published an image service and have the new fields enabled in catalog and in the service side but they are still not available in the service. Is there another step I am missing?

 

Thank you,

Hayleigh 

0 Kudos