Working in FMV, no data/video/anything is present in finalized multiplexed location.

2445
21
11-09-2016 08:23 AM
MarkGroom
New Contributor

Working within Full Motion Video, I have a .mp4 video file and its corresponding .csv file (both from Contour 2+ camera). When video multiplexing, I am able to get a success message within ArcMap; supposedly resulting in a MISB compliant video.

But the finalized, multiplexed output video is not in the output location i selected into the Video Multiplexer! There is simply nothing there (no video file, metadata, etc.). Does it save elsewhere, or is there a user error?

0 Kudos
21 Replies
JeffLiedtke
Occasional Contributor II

Hi Aleksandra,

Thanks for the csv file - it is helpful.  I see that the deliminators are semicolons, please convert these to commas.  Replying to your numbered items:

1)  Looks like the MP4 is likely fine

2)  Doesn't like those semicolons

3)  OK, I assume this app works and extracts the relevant metadata.

4)  The format looks good, but it may not be properly synced with your video frames if you selectively chose the metadata at 1 second intervals. We'll have to see your resulting multiplexed video file.  

5)  Yes, this is a pain, but you need to specifically format the UNIX timestamp column every time you open excel.  It is a case of MS being too helpful.

6)  The Phantom is recording RELATIVE height, whereas you need ABSOLUTE height.  So determine the true elevation value at your launch site (you can use the Esri Elevation service), then add the Phantom relative height to the actual elevation value.  Just add another column to your spreadsheet, enter the true elevation (say 500m) plus the Phantom height for all the cells (500 + 0 for the launch, 500 + 10 for the Phantom relative height of 10m, etc).  And add the field heading name of "Sensor True Altitude" to this new column and remove it from your Phantom altitude column, of course.

And so when calculating the 4 corner data in the Video Multiplexer tool, the average elevation to enter is 500 in this example.

Let us know how it works out for you.

Cheers,

Jeff

0 Kudos
AleksandraZietara1
New Contributor

Hi,

So, I have changed semicolons into commas but the output movie is still the same. I also prepared the new .csv file containing all the metadata (not only with the interval every 1sec) but it didn't change anything. Finally, I changed the elevation values to absolute heights (not a big difference as I am not more than 10m above see level) but it also didn't bring any changes while running Video Multiplexer. 

As I didn't have values for Sensor Relative Azimuth Angle, Sensor Relative Elevation Angle, Sensor Relative Roll Angle stored in the .log file from drone I just made-up these values in .csv file. May it be the problem? But as I understand it can lead to wrong geolocation of movie, but not to 'not creating movie at all'?

Just in case you want to examine .csv file, I am sending the new file with all the records. 

Thanks,

Aleksanda

0 Kudos
JeffLiedtke
Occasional Contributor II

I assume you mapped Yaw as the Platform Heading.  The values in your CSV look plausible, except the Sensor Relative Elevation angle of -10 is very shallow and the footprint of the video frame may have difficulty intersecting the ground. But the video should still process, although it may be missing some video footprints per the reason above. To eliminate one more variable, please rename your field headings in the CSV to the heading names specified in the field mapping template, and don't include the template as an input into the GP tool.

Can you attach your video?  We will try to multiplex it using this latest CSV.  Thanks.  Jeff

0 Kudos
AleksandraZietara1
New Contributor

Hello,

Link: https://drive.google.com/file/d/0ByG4dTI3zYX8LVBmVmlhS2Q1NWM/view?usp=sharing

Let me know if the link is not working. I am sending you the video, the original .csv log file, and .csv file prepared to use in video multiplexer. I have completely no more ideas what might be wrong.

Thank you very much for help.

Aleksandra

0 Kudos
JeffLiedtke
Occasional Contributor II

Hi Aleksandra,

Many Thanks for your video data.  I successfully multiplexed it using the csv metadata file (try_all2_proper_headings.csv) provided by Cody, in which he typed the proper MISB heading field names. It looks good and the video footprints on the map look plausible (I used the Esri Imagery Basemap).  One tiny detail which may have affected you - you also need to close the metadata CSV file before you run the multiplexer tool.  So after making sure the UTC timestamp column format is "Number" with 0 decimal places, save and close the file.

Otherwise, you did a good job on ensuring the UTC timestamp is in the correct format, and all the 11 required MISB-compliant metadata looks good.  I suspect you did all the "tricky" steps in preparing the metadata CSV just fine, but got hung up on dumb Excel procedural steps that are not intuitive.  They are not really "Esri issues" but rather Microsoft "Excell issues", but since these affect the workflow these need to be clearly spelled out in the help documentation, which I will pass on to the documentation team.

All the Best!

Jeff

CodyBenkelman
Esri Regular Contributor

Jeff - good point, I had forgotten to note that if the *.csv file is still open in MS Excel it will cause problems.  I'll review the documentation to be sure we emphasize that.

Aleksandra, I hope this is working for you now...?


Cody

0 Kudos
AleksandraZietara1
New Contributor

Hello,

I would love to say that it is working but unfortunately not. I also tried on different computer just in case something is wrong with mine but it also didn't work. So if you checked the video and .csv file and they are fine, maybe I am using Video Multiplexer in a wrong way or maybe there is something wrong with the version of ArcMap? I have 10.5 and also the FMV add-in is for 10.5. Is there something wrong with my input parameters in Video Multiplexer?

Thanks,

Aleksandra

0 Kudos
JeffLiedtke
Occasional Contributor II

You need to add an average ground elevation.  Your lowest value is 5.7m, so you could input 5.5m or perhaps 5m.  When I did my test I input 1m in case your drone was not sitting on the ground.

0 Kudos
AleksandraZietara1
New Contributor

I used 5 meters. It didn't help. Can it refer to any windows settings?

0 Kudos
CodyBenkelman
Esri Regular Contributor

Aleksandra

I have consulted with Jeff, but we don't know what might be wrong with your processing.  Your data works on our systems without any problem.  I'd suggest you open an incident with Esri Customer Support (http://support.esri.com/en/contact-tech-support ), and provide them as much information as possible regarding your version of ArcGIS, configuration and operating system of your computers (are they set to work in English or another language?), and all details regarding your failures - for example, send the verbose output from the multiplexer GP tool.   I hope they are able to help.  

Cody B

0 Kudos