Working in FMV, no data/video/anything is present in finalized multiplexed location.

2529
21
11-09-2016 08:23 AM
MarkGroom
New Contributor

Working within Full Motion Video, I have a .mp4 video file and its corresponding .csv file (both from Contour 2+ camera). When video multiplexing, I am able to get a success message within ArcMap; supposedly resulting in a MISB compliant video.

But the finalized, multiplexed output video is not in the output location i selected into the Video Multiplexer! There is simply nothing there (no video file, metadata, etc.). Does it save elsewhere, or is there a user error?

0 Kudos
21 Replies
JeffLiedtke
Esri Contributor

Mark,

When you save your CSV - presumably using MS Excel, please ensure that the format of your UNIX Time Stamp column is saved as a number with zero decimal places.  Excel insists on representing this 16-digit number in scientific notation - you need to ensure it is a saved as a number.  And the csv file needs to be closed before it can be used in the multiplexer tool.

Jeff

0 Kudos
MarkGroom
New Contributor

Jeff,

Thanks for the time-stamp conversion tip. I was able to convert the given contour video timestamp into Unix Timestamp, but when i multiplex the video and accompanying metadata together, I still receive a success message in ArcMap, but there is nothing present in the output location.

edit: if i am able to send you the video we are working with + its corresponding .csv metadata file, would you be able to look at it and see whats up?


Thanks

0 Kudos
JeffLiedtke
Esri Contributor

Mark,

I saw a post regarding time stamp conversion of your Contour data - but now I don't see it?  I'm including my response below in case this helps.

Regarding sending me your data - yes, I'd be happy to check it out.  Please review the steps below first to make sure your time stamp data is properly converted for use in the multiplexer.

Time Stamp conversion from human readable time to UNIX time.

Use the converter at http://www.epochconverter.com/ to make sure your time is UNIX time in microseconds (16 digits) - you may have to add 3 zeros to their milliseconds value (13 digits). Convert the first time stamp and the last time stamp, then subtract the first timestamp from the last timestamp to get the total time range of your metadata.  This should match the length of your video as a check.

 

In Excel, divide the total time range (see above) by the number of metadata records to get the average increment change. Then in the second record in your metadata table, add this increment change to the first timestamp value to get the proper timestamp value for the 2nd record. Select the first 2 cells in the timestamp column (one containing the beginning UNIX timestamp and the 2nd contains the incremental value added to the first value) and drag this formula all the way to your last record. All the timestamp records should be incremented properly.

 

Create a new column in your spreadsheet, and copy all the timestamp values computed by the formula into this new column as a value. Then delete the timestamp computed by the formula column and retain the UNIX timestamp written as values column.

 

Again – as a reminder - Excel insists on storing large numbers in scientific notation. When you save your updated csv file, make sure it is saved with the UNIX timestamp column [format cells] saved as a number with zero decimal places.

Let me know how this works for you.

Jeff

0 Kudos
MarkGroom
New Contributor

Jeff,

Thanks a lot for the information. I was able to convert the default time format to Unix. I would still love for you to take a look at our video and accompanying metadata file, as there is still no output multiplexed video.

If this is allowed, here is a Google Drive link that has the Contour video, .csv metadata file with updated Unix timestamps, and the original .csv metadata file: https://drive.google.com/drive/folders/0ByT7A9DByvfOakNyaGRoRnRteW8?usp=sharing 

We are going to be using FMV for field research next week, so I want to make sure I am able to successfully input georeferenced video into ArcGIS.

Thanks,
Mark

0 Kudos
JeffLiedtke
Esri Contributor

Hi Mark,

 

Thanks for your video and associated metadata, which were collected from a ground-based vehicle. It looked like the sensor was mounted on a stationary mount on the vehicle (not on a moving gimbal) with a fixed zoom setting.

 

I was able to create 2 videos with embedded metadata as described below, but would like to set some context first.

 

To create a MISB-compliant video, the FMV Video Multiplexer needs a minimum of 11 essential parameters to compute the map transform between the video frame and the map. This enables the display of the video footprint on the map in ArcMap, marking features in the video and map display, simultaneous display of GIS data on the map and the video player, searching video archives, and more.

The minimum metadata parameters are:

 

UNIX Time Stamp, Platform Heading, Platform Pitch, Platform Roll, Sensor Latitude, Sensor Longitude, Sensor Altitude, Horizontal FOV, Sensor Relative Azimuth, Sensor Relative Elevation, Sensor Relative Roll. See example csv below.

 

1433430000000000,320,0,0,39.919767,-105.117297,1690,65,0,-25,0

1433430001000000,320,0,0,39.919767,-105.117297,1690,65,0,-25,0

 

The Contour metadata contained only 5 of the 11 essential parameters, time stamp, latitude, longitude, heading and altitude. When multiplexed, these result in the sensor ground track displayed on the map in ArcMap with the sensor icon pointing in the correct direction based on the heading info. See the video and metadata csv I posted on your data download site. However, these few parameters alone do not support the computation of the video to map transform.

 

From the video, it looked like the sensor was looking 90 degrees from the vehicle and slightly down. Based on this, I assigned default values for the other parameters; pitch = 0 degrees, roll = 0 degrees, Horizontal FoV 120 degrees (the actual FoV would come from your camera specs), sensor relative azimuth = 90 degrees, sensor relative elevation = -5 degrees and sensor relative roll = 0 degrees. See the metadata csv file on the data download site.

 

Input both the video and the updated metadata csv file into the Video Multiplexer GP tool, expand the Calculate Corner Coordinates options and click the checkbox and input your lowest elevation value in the metadata; -4 meters in your case and hit OK. 

This results in a MISB-compliant video that enables marking and the other functionality mentioned above.

 

When creating your metadata csv with the required 11 parameters, use the MISB tag names in the csv supplied. Or the field heading names can be whatever you want and be mapped to the MISB tag names in the attachment. For more details about multiplexing metadata and video data, please refer to the FMV Users’ Manual at https://community.esri.com/docs/DOC-8607.

Good Luck with  your work!

Jeff

0 Kudos
AleksandraZietara1
New Contributor

Hello everyone,

It has been a long time since anyone posted with questions about 'Video Multiplexer'. I hope someone can help me with my issue.

I captured some georeferenced videos with the use of Phantom 4 Pro. I have log files from flight and I converted them into .csv files.

I 'reorganized' the .csv file in a way described by Jeff in the posts above.

The drone log file contains parameters equal to: UNIX Time Stamp, Platform Heading, Platform Pitch, Platform Roll, Sensor Latitude, Sensor Longitude, Sensor Altitude, Horizontal FOV. For Sensor Relative Azimuth, Sensor Relative Elevation and Sensor Relative Roll I assigned values based on my observations in a similar way as Jeff did in example above.

I am using Field_Mappind_Template file to connect heading from .csv file to MISB format.

I also converted my time stamp to UNIX format and made the 'number' field format in excel.

When I run 'Video Multiplexer' the process appears as complete but when I want to open videoor add in to ArcMap I get the message 'The video could not be loaded. Please chceck the file or stream and try again'.

I suspect the problem is with my .csv file but I have no more ideas what can be wrong. So maybe someone experienced something similar? Or maybe someone is also using Phantom 4 Pro and have another workaround?

Any help would be appreciated.

Aleksandra

0 Kudos
CodyBenkelman
Esri Regular Contributor

Aleksandra

This sounds like there might be a problem with the video, not related to the multiplexer.  Is it *.mp4 format?  Can you drop the raw video into the Video Manager and make sure it plays?  If that works, but the post-multiplex video does not, please let us know the file sizes of the two video files, and also how long the video is, and how long the GP tool ran when you did the multiplexing.  

If you can upload the *.csv file you input to the multiplexer, we can test it for proper formatting.  (I don't need the video)

Cody B. 

0 Kudos
JeffLiedtke
Esri Contributor

Hello Aleksandra,

I'm curious how you got the proper metadata extracted from your Phantom 4 and into a CSV. An app or utility provided by ?

A couple of quick things to check is whether your UNIX time stamp is in milliseconds - a 16-digit number.  And if you open your CSV file in Excel, be sure to specifically format the time stamp column as a number before saving the CSV, because Excel automatically converts the number to scientific notation even if you don't change anything in the CSV file.  And make sure you check the "Calculate Four Corner Data" box and assign an average ground elevation in the Multiplex Video GP tool.

Best,

Jeff

0 Kudos
AleksandraZietara1
New Contributor

Hello Cody and Jeff,

Thank you for the quick response. Some answers and explanations:

1. The video is in .mp4 format. The raw video plays when I drag it into Video Manager. It has no geolocation but plays with no problems. The movie is 30sec long and the size is 364MB. 

2. GP tool runs for about 6sec and the output .mp4 file is empty.

3. To get metadata from Phantom 4 Pro I used .log files stored in the tablet after the flight. They were in .txt format, so I used the http://www.phantomhelp.com/LogViewer/Upload/  to convert them into .csv files. As I only wanted to check if this is going to work I reorganized the file manually in excel to prepare it for use in Multiplexer. 

4. I  used the Epoch Converter - Unix Timestamp Converter . From the .log file I chose the records with 1s interval, so each row in .csv file has 6 zeros at the end.

5. The time stamp column is saved as the number, but every time I open .csv file again it is converted into scientific notation so I need to do it again and again. Is it correct way?

6. As I decided to use local height system, the first height recorded by Phantom is 0 meters, so when I check the 'Calculate Four Corner Data' as the average ground elevation I type '-10'm. (I found it on one forum that it should be lower that the smallest alltitude). Is it correct?

I believe the problem is one of my unresonable assumptions while creating .csv file compatibile with Multiplexer. The file you can find in attachment. 

Thanks,

Aleksandra

0 Kudos