Warning 71153 - Raster associated with mosaic dataset not georeferenced

1219
8
Jump to solution
04-13-2021 09:36 PM
Labels (3)
ChrisPy
New Contributor III

Hi guys,

I created a mosaic dataset and added rasters (JPG) that has spatial reference (when checked in ArcCatalog) and has a JGW world file. But when I analyze my mosaic dataset, I keep getting this warning. Anyone here has experienced this issue and resolved it?

Thanks,

Chris

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
ChrisPy
New Contributor III

Ok just an update. I did end up saving my rasters in a different format. Initially they were JPG format with world files. I had updated its spatial reference so many times but still the mosaic dataset analyzer keeps thinking that it does not have any spatial reference. So i converted the raster to JPG2000 format with the proper spatial reference. After doing that and recreating my mosaic dataset, running the mosaic dataset analyzer no longer picks up the warning of the raster not being georeferenced.

View solution in original post

8 Replies
JayantaPoddar
MVP Esteemed Contributor

At least one of the mosaic dataset items is not georeferenced properly. This usually means that the item is missing a spatial reference system or does not have valid coordinates.

Apart from checking the spatial reference of individual images in Catalog, also add all the images to the map, and see if they are overlaying properly (or any image sits elsewhere).

You may select and remove the associated raster following the steps in Mosaic Dataset Analyzer: Warning 71153 



Think Location
ChrisPy
New Contributor III

Thanks Jayanta. All rasters are lining up properly using their current spatial reference so it should not be the issue.

0 Kudos
ChrisPy
New Contributor III

Hi guys,

I created a mosaic dataset and added rasters (JPG) that has spatial reference (when checked in ArcCatalog) and has a JGW world file. But when I analyze my mosaic dataset, I keep getting this warning. Anyone here has experienced this issue and resolved it?

Thanks,

Chris

Tags (2)
0 Kudos
PeterBecker
Esri Regular Contributor

Check the options in ArcGIS Pro that World files are being used.

You will need to set this before you add the image. If the image falls in the correct place then you can ignore the analyzer warning.

PeterBecker_0-1618411767343.png

 

0 Kudos
ChrisPy
New Contributor III

Ok I'll give this a try and see if makes a difference.

0 Kudos
ChrisPy
New Contributor III

Hi Peter, that did not improve it. I opened a blank Pro project and made the update to the raster settings, then proceeded to add my mosaic dataset. I ran analyze tool and it still gives the warning. I want to resolve this issue as it might be tied to the issue im having when publishing a map service with this mosaic dataset, https://community.esri.com/t5/publishing-and-managing-services/mosaic-dataset-issue-when-published-a...

0 Kudos
ChrisPy
New Contributor III

Wondering if its worth exporting the rasters in different format that will properly save its spatial reference and avoid this warning.

0 Kudos
ChrisPy
New Contributor III

Ok just an update. I did end up saving my rasters in a different format. Initially they were JPG format with world files. I had updated its spatial reference so many times but still the mosaic dataset analyzer keeps thinking that it does not have any spatial reference. So i converted the raster to JPG2000 format with the proper spatial reference. After doing that and recreating my mosaic dataset, running the mosaic dataset analyzer no longer picks up the warning of the raster not being georeferenced.

View solution in original post