Turn values 255,255,255 into nodata; in image server

2449
3
12-21-2010 10:45 PM
Labels (1)
ElliottCarson
New Contributor III
Hi,

It seems a simple process, however I've been unbale to turn the 255,255,255 values into nodata through the image services edit raster properties. After I've finished with this wizard nothing happens.

What steps are required after the using the wizard?

Or am I going about this the wrong way?

Regards,
Elliott
0 Kudos
3 Replies
larryzhang
Regular Contributor
On our practices, the image service editor (in desktop ArcGIS 9.3/9.3.1 & 10)  does not provide any 'very effective' configuration or automatic functions to help us re-define footprints on user's needs, for example, to remove 255 255 255 or any artifacts along imagery boundary, which may affect interpretation after merging.

So, after finishing the wizard, the first thing to do is: manually to edit individual footprint one by one until satisfied, and save your modified footprints. And then, at least, the following steps should be used:

�?� re-build image service boundary;
�?� remove the previous overviews;
�?� re-define overviews;
�?� ... and finally,
�?� re-generate derived images & re-compile image service

If having ArcGIS 10 installed, you can have many automatic functions to do so in Mosaic Dataset. However, it is worth to mention that, very often you are still required to conduct manually-editing operation on some of footprints or boundary, even though the automation can remove majority of artifacts in ArcGIS 10.
0 Kudos
larryzhang
Regular Contributor
If you don�??t start with the wizard (i.e., create a fresh image service defination file), you can try �??Maximum data value�?? parameter in the Advanced tab by yourself. The document can be found out at http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=Recomputing_footprints_to_remove_unwan....

For some unknown reasons, mostly, it does not work very well for us. It's why manual editing operation is commonly used in our works, when using Image Service Editor.
0 Kudos
ElliottCarson
New Contributor III
Thanks for the help Larry,

I followed your advice of your first reply, I may have done it a little differently but it still worked. Your certainly put on the right path.

1. I ended up editing the bounday shape to show only the image area and remove the whitespace/nodata.

2. Then right clicked on the footprint layer and selected Recompute Footprint --> By Clipping Boundary.

3. Then in the image service drop down selected Advanced --> Build and in the dialog box I only checked the Generate derived images, Compile service.

Again thanks for the help.

Regards,
Elliott
0 Kudos