Site Scan Failing Preflight Checklist

310
2
Jump to solution
07-28-2021 01:40 PM
Labels (1)
AndrewSouthern
Occasional Contributor

Our organization has been testing Site Scan over the last few weeks and have been impressed with its capabilities.

However, we are running into some issues with our Inspire 2 failing on preflight checklist.  Ocassionally it runs right through the checklist and begins mission without issue, other times it spins on one of the checklist items and eventually errors or times out.  There's not really any rhyme or reason that we are noticing as to when it passes through the checklist and when it doesn't.  Our organization has a couple other drones and controllers that are able to run through the preflight checklist without any issue.

To me it seems like it's an issue of communication between the controller and the iPad.  Radio connectivity is good, however, and we are able to use DJI Ground Station Pro without any problems.  The issue seems to be specific to when trying to fly a mission in Site Scan.

I did find a setting within DJI GO 4 that allows for the controller to continuously charge the iPad (or phone) that it is connected to.  This afternoon I enabled this option so that the iPad is continuously pulling power from the controller and was able to run straight through the preflight checklist without any issues.  The connectivity during the flight seemed crisper as well with very little lag on the video feed from our Zenmuse X4S camera.  I'm not sure that it's related, could purely be a coincidence, but was curious if anyone else who uses Site Scan and has issues passing preflight checklist, especially with an Inspire 2.  

Thanks.

0 Kudos
1 Solution

Accepted Solutions
NicoBonnafoux
Esri Contributor

Hi Andrew, 

The Inspire 2 is usually an extremely reliable drone. You can view the status of your drone as reported by DJI in the upper right of the preflight systems check page. 
I'm confident that the iPad charging setting you found in the DJI app is unrelated to your issue. 

 

Based on the information you shared, I would suggest that you: 

- Ensure that your Site Scan Flight app and iPadOS are up-to-date

- Use a genuine Apple cable to connect your iPad and drone remote controller, third-party cables can cause communication issues. 

- Make sure to only have one app that communicates with the drone open (fully quit any DJI app when using Site Scan Flight). 

- Frequently format your SD card, especially if the Systems checks are failing on the Camera Checks. 

If this doesn't work, I'd encourage you to contact Tech Support  or your Customer Success Manager, and let them know what version of the app your are using. They'll help you extract app logs that will allow them to review exactly what is happening and provide you the best solution. 

Regards,
Nico 

 

View solution in original post

0 Kudos
2 Replies
NicoBonnafoux
Esri Contributor

Hi Andrew, 

The Inspire 2 is usually an extremely reliable drone. You can view the status of your drone as reported by DJI in the upper right of the preflight systems check page. 
I'm confident that the iPad charging setting you found in the DJI app is unrelated to your issue. 

 

Based on the information you shared, I would suggest that you: 

- Ensure that your Site Scan Flight app and iPadOS are up-to-date

- Use a genuine Apple cable to connect your iPad and drone remote controller, third-party cables can cause communication issues. 

- Make sure to only have one app that communicates with the drone open (fully quit any DJI app when using Site Scan Flight). 

- Frequently format your SD card, especially if the Systems checks are failing on the Camera Checks. 

If this doesn't work, I'd encourage you to contact Tech Support  or your Customer Success Manager, and let them know what version of the app your are using. They'll help you extract app logs that will allow them to review exactly what is happening and provide you the best solution. 

Regards,
Nico 

 

View solution in original post

0 Kudos
AndrewSouthern
Occasional Contributor

Thank you for your input Nico.  I have been in communication with a member of the Site Scan dev team and we are working through possible causes for these hangups.  

Site Scan is version 4.1.2 and iOS version 14.7.1.  I am using an authentic Apple cord, and have also tried using another cord without any change in behavior.

I'm careful not to have other apps running in the background as the problems that could cause was explained to us when we started the eval.

Today we submitted the logs so hopefully they will shed some light on what may be going on.  

0 Kudos