Split raster "overlap" option not working?

567
2
Jump to solution
09-16-2020 03:13 PM
FrancesBiles1
New Contributor III

We are trying to split a raster (DEM) into chunks based on boundaries in a polygon feature class (hydrologic units). We'd like the raster chunks to be larger than the polygon boundaries so that each chunk overlaps each other slightly.  It sounds like the Overlap option in the Split Raster tool should so this. The screenshot below shows what we entered for the tool, specifying a 100 pixel overlap. However the rasters output from the tool follow the polygon boundaries and have no overlap with adjacent polygons.  Either the tool is not working correctly or I'm not understanding how the Overlap function really works. I found an older post with this same question here, but it was not solved. I cannot find any more details about the Overlap option other than what is on the ESRI help page.

We are using ArcGIS Pro 2.6.1.  The Snap raster is set to the Input Raster. Both the raster and the polygon features are in the same coordinate system & datum.

Is the Overlap option meant to produce essentially "buffered" output rasters? If so, what are we doing wrong?
If not, what does the Overlap function do?

0 Kudos
1 Solution

Accepted Solutions
MehdiPira1
Esri Contributor

Hi Frances Biles‌,

I also tested this Split Raster tool and no success in getting the overlap to work. 

However, if you are now after a result I can recommend using the buffer tool to buffer your split polygons to whatever distance. Then apply the Split Raster tool (this time, leave the overlap 0) on the buffered polygons and the raster. you will get split rasters with overlaps based on the specified distance in your buffering geo-process.

View solution in original post

2 Replies
MehdiPira1
Esri Contributor

Hi Frances Biles‌,

I also tested this Split Raster tool and no success in getting the overlap to work. 

However, if you are now after a result I can recommend using the buffer tool to buffer your split polygons to whatever distance. Then apply the Split Raster tool (this time, leave the overlap 0) on the buffered polygons and the raster. you will get split rasters with overlaps based on the specified distance in your buffering geo-process.

FrancesBiles1
New Contributor III

Thank you Mehdi, that worked!

Is this a bug in the tool? If so, any plans to fix it? It sounds like it hasn't worked for a long time judging by the old post I found.

0 Kudos