Intersect tool output varies

238
3
07-19-2017 10:02 AM
New Contributor III

Has anyone ever had this problem?  When using the Intersect tool, on the same polyline data and two different polygon data sets, the output polylines differ in areas (see attachment).

Reply
0 Kudos
3 Replies
Esri Esteemed Contributor

To be honest I don't really understand the attached image. I don't see the two different polygons, but do see 3 different lines. 

There are a number of aspects that have influence on the results when doing an intersect., among these you will need to check the coordinate systems (are they all the same?) and what has been the XY tolerance?

Reply
0 Kudos
New Contributor III

Yes, Mr. Bakker, the coordinate systems are all the same.  I did apply a slightly different xy tolerance to each to make sure it would pick up lines slightly outside of the polygon boundaries.  The three lines indicate the input and two outputs (from two polygon sets applied to the input polyline).  It makes no sense to me though that the output results in lines being moved / offset horizontally from the original (input polylines). I could understand if it may leave out some line segments, based on the xy tolerance applied, but that seems to me all that should be modified in the topology.

Thank you.

Barry

Reply
0 Kudos
MVP Esteemed Contributor

compare the coordinates of the geometries.  I have seen cases when the onscreen display does not match the reality of the points making up the geometry.  This can be guaranteed when the coordinate system of one or more is not defined or mis-defined.  Other examples include clipping a feature which is in geographic coordinates, the end appears to move from its original course ... is it real? or is the geodesic shape changed?

Sometimes what you see, isn't ... so a comparative geometry would be interesting.

Reply
0 Kudos