Error Message during Geoprocessing

2139
3
01-04-2011 12:06 AM
paulbla
New Contributor
Hello, I got a Error Message while a Geoprocessing (not a ESRI-Tool):

ERROR 999999: Error executing function. Invalid Topology [Negative point valence.]

with ArcGIS 9.3.1 SP2.

Has somebody an idea, what the meaning this is

Thanks Jan
0 Kudos
3 Replies
MyunghwaHwang
New Contributor
Hi, memento21!

Did you find what causes this error?
I am getting the same error when I converted US 2000 census tract polygons into lines by using Polygon Into Line tool. This error didn't go away even when I converted the shape file into a coverage, cleaned the coverage, converted the coverage into a new shape file, and entered it into the Polygon Into Line tool. I tried to repair geometry and Arc says it did repair. Also, I checked the validity of geometry but no error was detected. Let me know if you found some solutions.

Myunghwa Hwang
0 Kudos
SergiosKolios
New Contributor
Hi Jan and Myunghwa,

I recently encountered the same issue, while executing a clip on a Road Network Layer for France.
I use an ESRI Tool, (Data Management --> Clip).
Error report is as follows:

ExecuteError: ERROR 999999: Error executing function.
Invalid Topology [Negative point valence.]
Failed to execute (Clip).

My dataset is the entire Road Network of Europe, geoproccessed per Country, and for large Countries such as France or Germany, seperated in several partitions. The Road Network is in-turn separated in many classes, and I am almost sure it's not a memory issue. 

Thank you in advance
Sergios
0 Kudos
SumangLiu
New Contributor
Hey All,
I got the same problem when using Clip tool. I have a feature class which contains a lot of points and I tried to extract all the points in New York County using clip tool. It failed and showed the following message:
ERROR 99999: Error executing function
Invalid Topology [Negative point valence.]
Failed to execute (Clip)

Does anyone know how do deal with it?
Thanks
Sam Liu
0 Kudos