Data loss when hillshading using a mosaic of raster files

2789
9
07-10-2014 02:27 AM
AlexanderPeace
New Contributor

Hi,

I have produced a mosaic of raster files in ArcMap using Create Mosaic Dataset and Add Rasters to Mosaic Dataset. At this point I have a dataset which appears to be functioning fine, however when I attempt to use the Hillshading (Spatial analysis) tool it develops holes. These holes are not always in the same places.

The Hillshading tool gives me no errors. The image below shows the same geographical area, with the raster mosaic and the hillshading.

Any help with solving this would be much appreciated.

Cheers,

Alex

screenshot_holes.png

0 Kudos
9 Replies
DanPatterson_Retired
MVP Esteemed Contributor

do you get the same effect if you mosaic to new dataset then hillshade? ArcGIS Help (10.2, 10.2.1, and 10.2.2)

0 Kudos
AlexanderPeace
New Contributor

if I Mosaic to new raster dataset I get the error 'Background processing has encountered a serious error and is unable to continue'.

Alex

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

strange...are you creating the new dataset in a folder?

0 Kudos
AlexanderPeace
New Contributor

I have tried it in the same folder and the data and outside it. I have also tried it in a geobase.

Alex

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

out of ideas...other trying a smaller subset of the data to see if it is a processing limitation

0 Kudos
AlexanderPeace
New Contributor

Ok will try that. Thanks.

0 Kudos
DavidJohnson5
Esri Contributor

Check the defaults tab of the mosaic Dataset properties window for the Maximum Number of Rasters per Mosaic setting.  The default value is 20.  It looks like you need double that value.  Just be aware that higher values will reduce performance since this setting controls how many rasters are dynamically mosaiced together.  Building overviews on the mosaic dataset will help with performance.

RajinderNagi
Esri Contributor

You can simply use hillshade function  (Hillshade function—Help | ArcGIS for Desktop ) on mosaic dataset and it will generate hillshade on-the-fly saving you disk space and time.

StefanieSteinbach
New Contributor III

Hi Alex,

Haver you solved your problem?

Stupid question - have you tried turning off background processing? I've had various (illogical) problems with it enabled and therefore always turn it off.

0 Kudos