When using a Geodatabase in Insights for ArcGIS, the line chart shows <No Data> although the selected field has no empty rows

405
1
Jump to solution
06-04-2019 02:25 AM
JacobFischer
New Contributor
First I created a dashboard in Insights for ArcGIS by using shp files zipped in 1 zip. I hade to trim down the GDELT data because a server time-out happened too often. See pictures 1,2,3,4
Dashboard: SHP dashboard 

After that, I made a similar dashboard but this time using a zipped GDB, because then I can display more points before a server time-out happens. But using a GDB creates the following problem for me: after I deselect GDELT in the predefined filter suddenly in the legend of my line chart <No Data> appears. Which is not displayed when GDELT is active (See pictures 5,6). In addition, the <No Data> legend colour doesn't even match the chart colour. GDELT is by far the largest layer. 
I created a third dashboard with another zipped GDB and the same thing happens. 
Does anyone know how I can solve this issue?
I included the dashboards in the post. It is possible to change the colour of <No Data> in the legend section, but the chart doesn't react to it. Making it 100% transparent doesn't make a difference either. In addition, it is not possible to filter <no data> out of the card. (see pictures 7+8)
Tags (1)
0 Kudos
1 Solution

Accepted Solutions
ScottSandusky
Esri Contributor

Hi Jacob, sorry for the very late reply.  It would be great if you could test this again, as we have had a lot of releases between the original post and now.  I am able to open your shp Insights workbook, but the GDB workbooks are't shared.  thanks, scott

View solution in original post

0 Kudos
1 Reply
ScottSandusky
Esri Contributor

Hi Jacob, sorry for the very late reply.  It would be great if you could test this again, as we have had a lot of releases between the original post and now.  I am able to open your shp Insights workbook, but the GDB workbooks are't shared.  thanks, scott

View solution in original post

0 Kudos