Upgrade of Oracle Geodatabase

994
2
Jump to solution
09-08-2017 05:56 AM
Highlighted
Occasional Contributor
I am trying to upgrade from 10.1 geodatabase to 10.5 when I run the upgrade check it says all is good to upgrade, but when I actually run the upgrade I keep getting an error. Here is the output of the script.

Executing: UpgradeGDB "Database Connections\GISPROD as SDE.sde" PREREQUISITE_CHECK UPGRADE
Start Time: Fri Sep 08 08:47:16 2017
Paused the database for upgrade.
There are no other active connections.
User has privileges required to upgrade.
Connected RDBMS instance is setup for ST_GEOMETRY configuration.
Running Pre-Requisite check (C:\Users\Raymondg\AppData\Roaming\ESRI\Desktop10.5\ArcCatalog\GISPROD as SDE.sde).
Instance supports XML type.
Updating server tables and stored procedures.
Could not update server tables and stored procedures. (branches : Error (406)
  DBMS error code: 406
ORA-00406: COMPATIBLE parameter needs to be 12.0.0.0.0 or greater
ORA-00722: Feature "SQL identity columns"

)
Refer to upgrade logfiles for more details:
C:\Users\Raymondg\AppData\Local\Esri\Desktop10.5\GDBUpgrade.log
C:\Users\Raymondg\AppData\Local\Temp\sde_setup.log
Unpaused the database.
Failed to execute (UpgradeGDB).
Failed at Fri Sep 08 08:47:17 2017 (Elapsed Time: 1.16 seconds)
Oracle Database: 12.1.0.2
OS: SLES 11 SP4

I am at a loss here. Any help appreciated.

Thanks

Ray
Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Esteemed Contributor

Hi Raymond,

Check what you compatibility parameter is by running the following query in SQL*PLUS:

SELECT name, value, description FROM v$parameter WHERE name = 'compatible';

Take a look at the following article about changing this parameter to 12.0.0.0.0:

Compatibility and Interoperability 

View solution in original post

2 Replies
Highlighted
Esri Esteemed Contributor

Hi Raymond,

Check what you compatibility parameter is by running the following query in SQL*PLUS:

SELECT name, value, description FROM v$parameter WHERE name = 'compatible';

Take a look at the following article about changing this parameter to 12.0.0.0.0:

Compatibility and Interoperability 

View solution in original post

Highlighted
Occasional Contributor

Thank you very much Jake. That did it. A few steps involved but that did the trick. If anyone else is looking for a bit of a tutorial.

  1. Shut down database instance - sqlplus>shutdown immediate
  2. Backup the spfile (copied to another folder)
  3. Delete the spfile
  4. Edited the init<sid>.ora file (set compatible=12.1.0.0.0)
  5. start the database (will use init<sid>.ora file to startup when no spfile found) - sqlplus>startup
  6. create new spfile from init file sqlplus>create spfile from pfile='<oracle_home>/dbs/init<sid>.ora'
  7. alter database - sqlplus>ALTER SYSTEM SET COMPATIBLE = '11.1.0' SCOPE = SPFILE;
  8. shutdown database(just to be sure) - sqlplus>shutdown immediate
  9. start database - sqlplus>startup

Appreciate the help

Ray