The ArcGIS10.4 desktop doesn't contain SQL Server client connect to SQLServer2008 R2?

698
3
07-29-2017 07:08 PM
Highlighted
New Contributor

The SQLServer DataBase is ok and the username and the password is right,why can't connect to SQLServer DataBase.

The arcgis server is 10.4,the SQLServer is 2008 R2.When I connect to database,it will show message "Connection was attempted with an older version of SQL Server client communications sofeware that is not supported.

I have installed SQLServer2008 R2,and use the "Microsoft SQL Server Management Studio" to connect database instance is ok.  

The ArcGIS10.4 desktop  doesn't  contain  SQL Server client connect to  SQLServer2008 R2?

If ture,which software I can download?   Where I can find it?

Why the ArcGIS10.4 desktop can't  compatible with SQLServer2008 R2?  The 10.4 is so high.

Tags (1)
Reply
0 Kudos
3 Replies
Highlighted
Honored Contributor

Connection to Microsoft SQL Server 2008 R2 is not supported with ArcGIS 10.4.x.

See Microsoft SQL Server database requirements for ArcGIS 10.4.x—System Requirements | ArcGIS Desktop for more details.

Highlighted
MVP Esteemed Contributor

As Jayanta pointed out, SQL 2008 is not supported in 10.4/10.5, but to answer your question about where to download client software , log into myesri, select your version of server and they are available under the Database Support files tab.

Reply
0 Kudos
Highlighted
Occasional Contributor

ArcGIS products at 10.3 level are last versions which support any SQL Server 2008 product. As SQL Server 2008 products are not certified to work with ArcGIS products at the 10.4.x and 10.5.x version it is in the clients best interest to be at least at the SQL Server 2012 version prior to upgrading to ArcGIS 10.4/10.5 products.

1)Deprecation Plan for ArcGIS 10.3 and ArcGIS 10.2.x
http://downloads2.esri.com/support/TechArticles/W32809_DEPRECATION_PLAN_FOR_ARCGIS_10_3_and_10_2_x__...

2)Microsoft SQL Server database requirements for ArcGIS 10.4
http://desktop.arcgis.com/en/system-requirements/10.4/database-requirements-sqlserver.htm