Same error when trying to create enterprise geodatabase "Failure to access the DBMS server".

572
4
08-18-2017 02:15 PM
Highlighted
New Contributor

We have already tried opening port 1434 and 1433 in SQL 2012 SP3. 

0 Kudos
4 Replies
Highlighted
MVP Regular Contributor
  • Is it possible to Turn-off the Firewall on the DBMS server and then check?
  • Are you able to ping the DBMS server from the ArcGIS Desktop machine successfully?
  • Do you have SQL Server Management Studio installed on the ArcGIS Desktop machine by any chance? If yes, can you connect to the instance successfully from there?
Highlighted
New Contributor

Thank you for the reply, we did turn off the firewall, but we will try the rest and report back! 

0 Kudos
Highlighted
Regular Contributor

We never use this tool when building our DB's but agree to start with steps from asrujit_pb‌ first.

Errors do look to be more connectivity related than permissions related but the error messages aren't always the best. Depending on whether you manage your own instance of SLQ Server or have a DBA it may be worth exploring this alternative option for creating your EGDB over the toolbox tools.

Build new DB in SQL Server and give it whatever name is desired (ex. GIS). Create the DBO account (ex. sde or GISAdmin) you wish to have own the new DB. Grant this account (GISAdmin) the DBO permission by setting: GISAdmin IS dbo statement. Create a new DB connection in ArcCatalog using the DB account GISAdmin. Right click on the new connection and go to "Enable Geodatabase". Process runs and essentially does what the ArcToolbox tools you showed are attempting to do except without having to use the SA account. Once the process has completed verify your connectivity to the EGDB. Go back into SQL Server and issue the change: GISAdmin AS dbo. You are all set to go but I'd also recommend at that point building and assigning your different schema's and schema owner accounts all within SQL.

0 Kudos
Highlighted
New Contributor

Thank you so much for commenting. If we can't get it to run after trying what Asrujit SenGupta mentioned to trial, we will follow your instructions! 

0 Kudos