Register postgresql 9.4.x geodatabase into ArcGIS Server 10.3

439
5
06-18-2017 07:47 PM
Highlighted
New Contributor II

Hello people!

I am currently developing an web application for my client. The conditions are :

- Geodatabase and sde schema are on Postgresql 9.4 whereas ArcGIS server is 10.3

- Geodatabase is on different machine with the ArcGIS Server and both are linux

- Both are access-limited since both are stored in a data center

I have successfully created the sde schema on postgresql. However, when i registered it into server, an error popped-up as follows

My first guess is that arcgis server 10.3 does not support postgresql 9.4. Since i am a newbie in this kind of thing, i really beg for solution from you guys!! Help!!!!

Thanks before! Have a nice day

0 Kudos
5 Replies
Highlighted
MVP Regular Contributor

Your guess was spot on.

PostgreSQL database requirements for ArcGIS 10.3.x—Help | ArcGIS Desktop 

Minimum supported database versions

PostgreSQL 9.3.5 (64 bit)

  • PostGIS 2.1

PostgreSQL 9.2.9 (64 bit)

  • PostGIS 2.0

PostgreSQL 9.1.14 (64 bit)

  • PostGIS 2.0

Highlighted
New Contributor II

Thank you for the prompt response,

I have 2 questions about your response which are:

1. Isnt it only applied in ArcGIS Desktop not in server environment???

2. The statement said that it is minimum so it is suppose to support 9.4. Or do i perceive it in a wrong way??? 

Thank you.

0 Kudos
Highlighted
MVP Regular Contributor

1. No, its the same for both Server and Desktop. If you check the bottom of this link ArcGIS Server 10.5 system requirements—Installation Guides (10.5) | ArcGIS Enterprise , it lists the supported databases. Those links state the same thing and directs you to the same page I provided earlier.

2. No, the links mention the Base version which is supported with that ArcGIS release.

Example: PostgreSQL 9.3.5 (64 bit)

This indicates that 9.3.1, 9.3.2, 9.3.3 & 9.3.4 are not supported at ArcGIS 10.3.x

However, versions higher than the base Supported version (in this case 9.3.5), that is, 9.3.6, 9.3.7 and so on are supported.

Highlighted
New Contributor II

First of all thank you Mr Sengupta. For the first answer it is crystal clear. But on the second one, you said so on are supported. This "so on" version you mean, it does not go up to 9.4, doesnt it? 

Well if it is, its a big disappointment then since lots of the data have been migrated to the 9.4 database.

0 Kudos
Highlighted
MVP Regular Contributor

No, that "so on" was meant for any 9.3.x versions.

Whenever 9.4.x will be supported, it will be mentioned separately. 

0 Kudos