Problem with replica creation and synhronization of changes

3112
4
06-10-2015 03:43 AM
Highlighted
New Contributor

hello,

I have two databases that I am dealing with. Both are Postgres(postgis) db on Posrgresql 8.3 server. I am accessing them through ArcSDE 10, and for all operations that I am performing I use ArcGIS(Map or Catalog). One of db is main db for which we are doing editing, adding new data etc. Another db is using for publication purposes, it is read-only db. Till one week ago everything was ok, we have had one-way replica created between databases, and after some new records or editing of existing we compressed main db and synchronize changes between databases.

But right now it does not work. Changes in main db can not apply to replica db. When I access main db through PgAdmin I can see new or deleted features in a and d tables, and after compression it is stored in base tables (that is OK). But after that when I do synchronization (connected) of changes with previously created replica, changes do not applied to replica db (it look like synchronization process starts, but is last very short and there is no changes inside of replica db).

I tried to create new replica, but it did not succeed. The error message is always like this:

I have tried to create new replica for existing databases and also i tried it with other(new/old) databases on the same server, but it is always without success. All datasets are versioned and Global ID are created.

If you have any idea or solution please post it.

Reply
0 Kudos
4 Replies
Highlighted
Esri Esteemed Contributor

Hi Milica,

Try creating a one-way replica from each SDE geodatabase to a File Geodatabase.  This will help determine if the problem is related to a particular geodatabase.

Reply
0 Kudos
Highlighted
New Contributor

Tnx Jake,

I have tried it with geodatabase but result is the same Error 000582. This is case when i try to create replica through ArcToolbox-Data Management Tools.

When i am using Arc Map-Distributed Geodatabase Toolbar-Create Replica I succeed  to create replica, but in replica db all new datasets with data from main db are created, beside existing datasets and when i try to synchronize changes after that nothing happens.

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

It's tough to determine what's going on here.  I would recommend calling Tech Support to further trouble shoot this.

Reply
0 Kudos
Highlighted
New Contributor

I have tried it with geodatabase but result is the same Error 000582. This is case when i try to create replica through ArcToolbox-Data Management Tools.

When i am using Arc Map-Distributed Geodatabase Toolbar-Create Replica I succeed  to create replica, but in replica db all new datasets with data from main db are created, beside existing datasets and when i try to synchronize changes after that nothing happens.

Reply
0 Kudos