No Empty Geometries exist but Validate Topology Failed - "the operation was attempted on an empty geometry"

170
1
02-18-2020 02:27 PM
Highlighted
New Contributor II

I'm trying to validate the existing topology of a polygon feature class (roughly 2.8 million features) that exists inside a feature dataset on our ArcSDE database. The topology validation fails with after an hour and 20 minutes with the error "Validate topology failed - the operation was attempted on an empty geometry". 

I've confirmed no empty or null geometries exist in the data. I used both the ESRI Check Geometry tool and some Oracle SQL queries to confirm. 

SELECT * FROM LAYER WHERE SDE.ST_ISEMPTY(SHAPE) =1;
SELECT * FROM LAYER WHERE SDE.ST_AREA(SHAPE) IS NULL;

There are some very small features (< .000001 square feet each) and self intersecting polygons (found by ESRI's Check Geometry tool) but testing has proven that the topology can be validated when these polygons are included in a sample of the data. The only error returned by the Check Geometry tool was the self intersecting polygon error. 

The feature dataset was changed to versioned to un-versioned before attempting to validate the existing topology. 

I'm not finding much help online so i'm hoping someone here may have something to offer. Any ideas about why validation is failing when no empty geometries exist?

Thanks in advance!

Reply
0 Kudos
1 Reply
Highlighted
New Contributor II

I ended up moving a copy to a file geodatabase and creating a topology and validating it there. It was successful. I suspect the issue validating the existing topology on our SDE is due to the fact that it was created with Desktop 10.4.1 and we're now using Desktop 10.6.1, but I can't be sure. 

Reply
0 Kudos