Is_Simple returns FALSE for any feature class in the root of SDE

2251
1
04-28-2015 10:37 AM
Highlighted
New Contributor II

If I create a Feature Class in python (arcpy.CreateFeatureclass_management) in SDE (just in the root, not inside a Feature Dataset), I am getting "FALSE" from sde.IS_SIMPLE in SQL Server. I thought a new Feature Class would be simple. I'm getting the same "FALSE" for any Feature Class in the root of the GDB on SQL Server, but I get "TRUE" for features in Feature Datasets.

Here's the python code I used to create the feature:

arcpy.CreateFeatureclass_management(out_path="Database Connections/sde_conn.sde",out_name="test_fc",geometry_type="POINT",template="#",has_m="DISABLED",has_z="DISABLED",spatial_reference="GEOGCS['GCS_WGS_1984',DATUM['D_WGS_1984',SPHEROID['WGS_1984',6378137.0,298.257223563]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]];-400 -400 1000000000;-100000 10000;-100000 10000;8.98315284119522E-09;0.001;0.001;IsHighPrecision",spatial_grid_1="0",spatial_grid_2="0",spatial_grid_3="0")

In SSMS, I run SELECT sde.IS_SIMPLE('dbo', 'test_fc') and it returns FALSE. I was expecting a new feature class to return TRUE. Does the FALSE here make sense?

Tags (2)
Reply
0 Kudos
1 Reply
Highlighted
New Contributor II

After taking a closer look at this, the "is_simple" will return FALSE if there is a relationship class in the same directory as the feature you are checking. If you start with an empty geodatabase in SQL Server, create three feature classes (testA, testB, testNoRel), and check IS_SIMPLE, all three will return TRUE. If you create a relationship class between 2 of them (testA and testB), IS_SIMPLE will return FALSE for all three, including the feature class that does not participate in a relationship class (testNoRel).

It seems like the third feature class that does not participate in a relationship class should return TRUE for is simple. Is there a reason why this would return false?

Reply
0 Kudos