How to Remove Domains in SDE When Domain Owner is Blank?

3708
5
Jump to solution
10-23-2015 09:47 AM
Highlighted
Occasional Contributor

I was adding new domains into our Oracle SDE 10.3.1 geodatabase. All was going well until I noticed that the 'Domain Owner' field was missing. Without it it populated, I can't go in and add/delete/modify those codes. Any suggestions on how to assign the domain owner? See attached screenshot.

Thanks,

MarkMissing Domain Owners.png

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
New Contributor II

Close the ArcMap/ ArcCatalog, and then reconnect, are you able to see the domain owner?

View solution in original post

5 Replies
Highlighted
MVP Frequent Contributor

Adding some of the ESRI Geodatabase experts so they will see this faster:

Jake Skinner

Asrujit SenGupta

Vince Angelo

Chris Donohue, GISP

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Are you receiving any errors when trying to delete them?

Are there any feature classes that are using those domains currently?

Who was the original owner of those domains? Are they still a user in the geodatabase?

Can you try with the geodatabase administrator to delete them?

Here some documentation on removing domains: Delete Domain—Help | ArcGIS for Desktop

Hope this helps......

-George

Managing DataEnterprise GIS

--- George T.
Highlighted
Regular Contributor II

What does the following SQL Query return:

select * FROM [GDB_ITEMS] where name like '%CARDINAL%'

Please do not attempt to delete any records from this table or edit any tables in the backend. This query is just for testing.

Reply
0 Kudos
Highlighted
New Contributor II

Close the ArcMap/ ArcCatalog, and then reconnect, are you able to see the domain owner?

View solution in original post

Highlighted
New Contributor III

this worked for me. The old close and re-open trick!

Reply
0 Kudos