Fields in Attribute Table for ArcGIS Pro Keep Moving Around, Why?

1659
2
01-20-2017 03:47 PM
Highlighted
New Contributor

I have a certain order I would like my fields in my attribute table to be arranged. Not a wild notion. It would explain why you are capable of moving the fields around in the first place but I would like these fields to remain where I move them, which is not the case most times I close the window or switch to a new tab. This has become annoying to the extreme as it hinders my representation of data to coworkers and higher ups. There is another problem I know others have tried addressing and which I hope has been fixed in 1.4 update but I thought I would mention as well here. When you do something as simple as switch from one tab to another the attribute tables will refresh and start at the beginning of the table which for large data sets is very time consuming and just plain bad coding. These two issues would greatly help my work flow and make my situation much better. 
PS: Building a Geodatabase and this doesn't help the progress

Reply
0 Kudos
2 Replies
Highlighted
MVP Esteemed Contributor

quirky.... From PRO 1.4

You can reorder columns in the attribute table directly, and the action can be undone. You no longer need to switch to Fields view to reorder columns in the table.

From... the Tables section of What's new in ArcGIS Pro 1.4—ArcGIS Pro | ArcGIS Desktop 

I didn't know there was a fields view in the first place... (I should open tables more)

Highlighted
Occasional Contributor II

I just spent a couple of hours fighting with field order in Pro 1.4.1. I’ve decided that it’s best to set up popups as much as possible in Pro before publishing to AGOL or Portal.  Today map has  lot of layers, so that was a lot of popups to check and fix.

 

It isn’t possible to manually reorder the fields in the Popup setup window. So I tried to reorder them in the Fields View, but they won’t budge in v1.4. That worked with 1.3. Next I tested reordering in the Attributes Table. That worked and the order stayed, except for one problem. If I tried to move the first field (leftmost), crash. Other fields moved without problems. Once I had reordered in the Attributes and saved the project, the change was usually reflected in the Field view. Not always, but usually.

 

On to the Popups. In the popup setup field list, the field order didn’t change sometimes. Sometimes the field order changed, but the popup itself still showed the wrong order. Rechecked the order in the Fields view and Attribute tables. All OK. I tried toggling random popup fields on and off to see if that would get Pro to refresh. I discovered that changes like that will “take” only if I return to the initial Popup setup view (top left arrow). That behavior is in the documentation, but certainly not intuitive. There should be a save/apply button.

 

However, that trick didn’t help with the field order problem. After checking the popups of other layers and several Saves, I rechecked the reluctant popups. They were finally showing the way I wanted.

 

I’m pretty sure that this isn’t a case of me suddenly doing something different that finally fixed the problems. It may be a problem with the popup configuration not refreshing quickly. But it cost me far too much time.

Reply
0 Kudos