Error creating a user or a Oracle 19c geodatabase on ArcGIS Pro 2.6.3 or ArcMap 10.8.1

981
8
Jump to solution
12-01-2020 05:29 PM
RafaelFernandes_de_Souza
New Contributor III

I am receiving an error when trying to create an Enterprise Geodatabase or when creating a database user on Oracle 19c using ArcGIS Pro 2.6.3 or ArcMap 10.7.1, 10.8 or 10.8.1.

Please, see the attachment.

 

 

Reply
0 Kudos
2 Solutions

Accepted Solutions
George_Thompson
Esri Frequent Contributor

Ok, thanks for that additional information.

You may need to create the database (shell) in a container


A new option starting with Oracle 12c, called Multitenant Architecture, consisting of a container database that can hold many pluggable databases, is supported at the pluggable database level. ArcGIS supports the same functionality in pluggable databases as is supported for Oracle 11g R2.

https://desktop.arcgis.com/en/system-requirements/latest/database-requirements-oracle.htm


Can you try that and report back?

--- George T.

View solution in original post

Reply
0 Kudos
RafaelFernandes_de_Souza
New Contributor III

Hi @George_Thompson, The problem was not related with being or not a container. 

They created the db in their environment. I think that was something wrong that I did in configuring Oracle in my environment to test.

 

 

View solution in original post

8 Replies
George_Thompson
Esri Frequent Contributor

Can you provide some more information:

  • Screen shot of the GP tool parameters entered?
  • Is this an existing Oracle database or are you expecting the tool to create an Oracle DB and add the geodatabase functionality?
  • If existing, can you connect to the DB from Pro with a DB user (with just connect)?

Any other information that you can provide on the Oracle side would be useful. Thanks!

--- George T.
Reply
0 Kudos
RafaelFernandes_de_Souza
New Contributor III

Hello George.

In the parameters I entered the instance and db info, sys password and sde password to create sde user. I have provided the keycodes file too.

The instance already have the database created.

I can connect to the database with the info provided to the tool with sys user.

 

Reply
0 Kudos
RafaelFernandes_de_Souza
New Contributor III

George,

On the Oracle side, I just installed and created the database with sys and system users enabled.

The database is not container.

 

Reply
0 Kudos
George_Thompson
Esri Frequent Contributor

Ok, thanks for that additional information.

You may need to create the database (shell) in a container


A new option starting with Oracle 12c, called Multitenant Architecture, consisting of a container database that can hold many pluggable databases, is supported at the pluggable database level. ArcGIS supports the same functionality in pluggable databases as is supported for Oracle 11g R2.

https://desktop.arcgis.com/en/system-requirements/latest/database-requirements-oracle.htm


Can you try that and report back?

--- George T.

View solution in original post

Reply
0 Kudos
RafaelFernandes_de_Souza
New Contributor III

I will try and report back.

 

Reply
0 Kudos
RafaelFernandes_de_Souza
New Contributor III

George,

I contacted the Oracle support and we solved this issue of create enterprise geodatabase.

Thank you a lot for the help.

 

Reply
0 Kudos
George_Thompson
Esri Frequent Contributor

Was the issue related to the DB not being a container?

Appreciate the update.

--- George T.
Reply
0 Kudos
RafaelFernandes_de_Souza
New Contributor III

Hi @George_Thompson, The problem was not related with being or not a container. 

They created the db in their environment. I think that was something wrong that I did in configuring Oracle in my environment to test.

 

 

View solution in original post