Enable Enterprise Geodatabase tool tries to use SDE schema when it should use DBO

272
1
Jump to solution
02-25-2020 02:54 AM
Highlighted
New Contributor II

Hi

I'm trying to enable an Enterprise Geodatabase in SQL Server 2016. The database is created and I have a windows account with DB_OWNER rights on the database. The login of the windows accounts is mapped to the username (domain\loginname) and the dbo schema in the database .

I have created a connection file with Operating System Authentification selected, but when I run the Enable Enterprise Geodatabase tool in ArcGIS Pro 2.5 it fails right after setting the snapshot-states with the error below:

Validated authorization file.
User has required privileges for geodatabase setup.
XML support is enabled for the database instance.
Successfully enabled database option ALLOW_SNAPSHOT_ISOLATION and READ_COMMITTED_SNAPSHOT.
[Underlying DBMS error]
See the setup log in the following location for additional error information:
C:\Users\<user>\AppData\Local\Temp\sde_setup.log
Could not create  geodatabase tables and stored procedures.
Failed to execute (EnableEnterpriseGeodatabase).

In the sde_setup.log:

[10:47:58.535] Error creating VERSION table. (-51)
[10:47:58.535] DBMS error code: 2760
[Microsoft][ODBC Driver 17 for SQL Server][SQL Server]The specified schema
name "sde" either does not exist or you do not have permission to use it.




[10:47:58.535] SDE schema object install not completed.
[10:47:58.538] ERROR installing/upgrading ArcSDE, Error = -51

And that is true. I want an DBO schema not a SDE schema.

But how do I persuade the tool to create the DBO schema instead?

Is there something wrong with the user mapping? In another environment with an SQLEXPRESS instance I can enable the geodatabase but in that environment my windows user is mapped not only to the dbo-schema but also to the dbo user in the database - is that the way to go?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
MVP Regular Contributor
Reply
0 Kudos
1 Reply
Highlighted
MVP Regular Contributor
Reply
0 Kudos