Getting to Know ARCGIS Fourth Edition Exercise 20a

323
2
Jump to solution
07-25-2021 04:01 AM
FORESTWEBB
New Contributor II

I am trying to work through exercise 20a , however I've encountered a problem with the Polygon To Raster tool in the ModelBuilder. I am using ArcMap10.8. The exercise has you "Add Field" -  "PERC_UNDER5" to Study Area Block Groups which creates an intermediate dataset in Study Area Block Groups 2. You then "Calculate Field" PERC_UNDER5 from Study Area Block Groups 2 which results in  intermediate dataset Study Area Block Groups 3. You then use Study Area Block Groups 3 with the Polygon to Raster to to create an Output Raster Dataset called "children.

The "Add Field" and "Calculate Field" tools appear to be working correctly as the Attribute Table for Study Area Block Groups is amended to include the PERC_UNDER5 field populated with appropriate values.

However when you add the "children" dataset to the display the values read from 3.40282e+38 to -3.40282e+38.

I saw a feed on Reddit where another user was experiencing the exact same problem.

I've followed the steps in the book to the letter.

0 Kudos
1 Solution

Accepted Solutions
FORESTWEBB
New Contributor II

I discovered the solution - In step 24 of the Exercise the instructions specify to set the Cellsize to 100 in the Polygon to Raster Tool. However I noticed when trying to reset the tool the Cellsize had a default value of .00082. When I ran the tool using this default value I got the results I anticipated seeing from the Exercise.

View solution in original post

0 Kudos
2 Replies
FORESTWEBB
New Contributor II

I believe my problem is related to the fact I am operating on a 64 bit operating system. There is a note in the Calculate Field tool that Field calculations with a VB Expression type are not supported on 64-bit products. To successfully use these products the expression should be converted to Python. 

Therefore i tried resetting the Expression and Expression Type from VB to Python. When I do this the children display reflects the newly calculated values ...HOWEVER the Python values are incorrect.

 

 

0 Kudos
FORESTWEBB
New Contributor II

I discovered the solution - In step 24 of the Exercise the instructions specify to set the Cellsize to 100 in the Polygon to Raster Tool. However I noticed when trying to reset the tool the Cellsize had a default value of .00082. When I ran the tool using this default value I got the results I anticipated seeing from the Exercise.

View solution in original post

0 Kudos