Data download script exports schema only

1629
6
01-22-2013 06:38 AM
LaurelKish
New Contributor III
I am using the "Extract Data and Email Task" model with associated scripts in my Geoportal 1.2.2 exactly 'as-is' from the System Toolbox. Only changes made were those required by documentation, ie. SMTP email server,  To/From email addresses, subject line, after adding it to my .mxd. When I use the data download tool within Geoportal, I receive a copy of the schema, but no records for my downloaded data. This occurs when choosing both a shapefile or file geodatabase as my export format. Has anyone else had this problem and what is the solution? Thanks.
0 Kudos
6 Replies
CliveReece
Esri Contributor
Not seen this behavior before.  Have you verified that the Extract Task works from running it within ArcMap?  Verified the Extract Task works from the ArcGIS Server REST API?
0 Kudos
LaurelKish
New Contributor III
Runs fine from ArcMap, but same result from job submitted thru REST endpoint.
0 Kudos
CliveReece
Esri Contributor
Then (most likely) the issue lies with how the ExtractTask is deployed and configured on ArcGIS Server.  Can you check if the ArcGIS Server account (arcgis or arcsoc) has all the write/read/execute privileges it needs on the folders being used by the Extract Task? 

You might want to review the information in this link: "Making your data accessible to ArcGIS Server", http://resources.arcgis.com/en/help/main/10.1/index.html#/Making_your_data_accessible_to_ArcGIS_Serv...
0 Kudos
LaurelKish
New Contributor III
When I test the extract from REST endpoint various folders and gdb's get written to the ..\arcgisserver\arcgisjobs folder on the host machine. I think permissions are okay as this server was set up exactly the same as all our other servers and I don't think the schema could be exported w/o the correct permissions. Temporary gdb's also have schema, but no records.
0 Kudos
LaurelKish
New Contributor III
I fixed my problem, even though I'm not quite sure what the real issue was. Since it seems a lot of posts go unresolved on this forum I thought I would share my experience and maybe save someone a big headache.
I could find no clear documentation of this but when publishing the Data Extract and Email gp service to Server from a map document (.mxd) I had to first publish the .mxd without the gp task. Then add the gp task to the TOC in the map, save the .mxd, now publish the gp service.  Now the data download task works from the REST endpoint and from the Download tab in my Geoportal app. Hoo-ray!
0 Kudos
CliveReece
Esri Contributor
Glad to hear you were able to solve the issue!  Thanks for posting your solution.
0 Kudos