ArcGIS Map Services Not Harvested

2749
1
04-04-2012 07:33 AM
MicheleDunham
New Contributor
I have installed Geoportal 1.2 as a pilot implementation using SQL Server and our LDAP metadirectory.  I followed the installation guide and completed the smoketest successfully.  I published a map service from our ArcGIS Server (http:/maps) and I published a feature dataset with the Publish client from ArcCatalog.  Next, I would like to harvest our ArcGIS Server's REST map services directory, but I'm having trouble getting this to work.  Our map services are located in a subdirectory of the ArcGIS Server ROOT directory...http://maps/arcgis/rest/services/MSDs/.  When I try to add this URL and the corresponding SOAP URL the Geoportal recognizes the connection.  However when I try to synchronize the process fails and the synchronization report says nothing was harvested.  Please see attached screenshot.  Do I need to make some changes in the gpt.xml file?  Is it possible there are some special permissions settings that need to be set on the ArcGIS Server?  I did try to follow along with the ArcUser article from Summer 2011 that explains how to do this but the article references some tables with settings to be changed in gpt.xml and I can't find a link anywhere to these tables.
Thank you.
0 Kudos
1 Reply
MicheleDunham
New Contributor
I found when I substituted the DNS alias "maps" for the actual ArcGIS Server's machine name the harvest worked.  It read all 40 map services but listed only the last one in the Geoportal catalog under the title.  This is such an incredilbly useful capability it would be helpful to have more in-depth examples and documentation on publishing ArcGIS Server REST services.
0 Kudos