Erfaringer med ARCADE

196
8
Jump to solution
02-25-2020 01:33 AM
SanneMikkelsen
Occasional Contributor

Mon der er nogen der har erfaringer med ARCADE og har lavet labels, der viser z-værdien på punkter? Jeg har fundet svar på Geonet, som ikke virker for mig:-( 

Tags (1)
Reply
0 Kudos
1 Solution

Accepted Solutions
XanderBakker
Esri Esteemed Contributor

Hi Sanne Mikkelsen ,

Sorry for answering you in English, but I don't speak Danish. From what I understand from the translation you want to label the Z value of a point. I asume you have tried:

Geometry($feature).z

This should work. I just tried and created a point geometry with a Z value using the playground and accessed the z property and it worked like normal:

var pointJSON = {"x": 1000000, "y": 1000000, "z": 15.123, "spatialReference": { "wkid": 3857 } };
var pnt = Geometry(pointJSON);
return pnt.z;

Do you get any error message or is the result just null?

View solution in original post

Reply
0 Kudos
8 Replies
XanderBakker
Esri Esteemed Contributor

Hi Sanne Mikkelsen ,

Sorry for answering you in English, but I don't speak Danish. From what I understand from the translation you want to label the Z value of a point. I asume you have tried:

Geometry($feature).z

This should work. I just tried and created a point geometry with a Z value using the playground and accessed the z property and it worked like normal:

var pointJSON = {"x": 1000000, "y": 1000000, "z": 15.123, "spatialReference": { "wkid": 3857 } };
var pnt = Geometry(pointJSON);
return pnt.z;

Do you get any error message or is the result just null?

View solution in original post

Reply
0 Kudos
SanneMikkelsen
Occasional Contributor

Hi Xander

Yes I have already tried 

Geometry($feature).z

I just get Null 😞

Reply
0 Kudos
XanderBakker
Esri Esteemed Contributor

Hi SanneMik , 

Have you verified that the information was published with Z-values? Null value would be returned if you don't have z-values (z not enabled) or they are filled with null values. 

Reply
0 Kudos
SanneMikkelsen
Occasional Contributor

Jubii! It works now.

I found out that it is the "test"-function that does not work properly. And the OK-button is not translated right to danish. UPS.

Thank you for your quick answer.

I adjusted it to

'Kote ' + Round(Geometry($feature).z, 2) 

Nice:-)

XanderBakker
Esri Esteemed Contributor

Hi SanneMik ,

Congratulations. I am glad you could make it work!

KlausDons3
New Contributor

Hej Sanne

Jeg melder fejlen i oversættelsen på den danske version. Det er på høje tid at vi får det fikset. 

KlausDons3
New Contributor

Hi Sanne

Vi fik oprettet en BUG på oversættelsesfejlen så vi forhåbentligt kan få det rettet til én af de kommende versioner af ArcGIS Online:

BUG-000129191: In the Danish edition of ArcGIS Online there is a translation error in the Arcade editor window, the OK button is translated to '".prvs" er en ugyldig fil til en enkeltbrugerautorisation.' instead of OK.

Tak fordi du gjorde os opmærksom på problemet.

Bedste hilsner

Klaus

SanneMikkelsen
Occasional Contributor

Hej Klaus

Fint at det bliver rettet på et tidspunkt. Det var dog ikke helt den samme tekst der var på min, men mon ikke det bliver rettet alligevel.

Ellers skal jeg gerne sende et screendump.

/Sanne

Reply
0 Kudos