Can't add asset type to the Electric Utility Network

04-17-2020 07:30 AM
New Contributor III


I've been looking for documentation explaining the process to add new asset type in the Utility Network, but I haven't found any details for doing this other that simple updating the attribute domain assigned to the Asset Type field at the subtype level. Here is the list of steps that I had to do to update the attribute domain, many of them not mentioned in the documentation, and at the end the ElectricNetworkEditor map using the utility network service didn't show the new asset type:

  1. Disabled the network topology. To update other attribute domains I didn't have to do this, but the first time that I tried updating the domain asset type with the topology enabled I got an error. Important detail not mentioned any where in the documentation available. 
  2. Stop the service for the utility network web layer to unlock the tables and be able to update the domain with the asset type of interest.
  3. Added the new code and description to the asset type domain following the recommendation to use a unique code to avoid code conflict with existing asset types in other subtypes.
  4. Save the changes to the domain. Since the domain was already assigned to the Asset Type field at the subtype level, I didn't re-assigned the domain to the Asset Type field. When updating other attribute domains I never had to re-assigned the domain to the field to see the changes, so I followed the same logic.
  5. Re-started the service and enabled the network topology.
  6. Went to the Asset Group with the modified Asset Type, but the new asset type was not available.
  7. Tried update the symbology but the new code for the added asset type was not available there either.
  8. Went back to the database connection to check if the changes to the domain asset type were saved, and that was positive.
  9. Disable the topology again, and ran the tool "Assign Domain to Field" to force the updated domain to the subtype and field of interest. The tool ran without error.
  10. Re-enable the topology. Then checked the layer again for the new asset type, but nothing changed.
  11. Refreshed the database connection. Also, re-set the data source for all the layers on the map. Still no new asset type appeared.

The pictures below show some of the steps in Arcgis Pro.

      Picture showing the modified domain.

      Picture showing the domain assigned to the asset type field at the subtype level, also the asset group on the map doesn't reflect the new asset type (LV Handhole).

The Electric Utility Network Foundation advance modelling considerations has this information about asset types:

From the Utility Network configuration documentation:

0 Kudos
0 Replies