Why one of the 3 clipped Landsat images does not completely overlap with 2 others in ArcMap?

337
8
Jump to solution
10-03-2017 09:32 PM
Labels (1)
MohammadRedowan
New Contributor II

I am working with 3 time-series Landsat data for forest attributes (cover, biomass etc). The whole scene (185 x 185 km) images overlap in ArcMap display completely. However, when I subset/clip the images to my study site using a polygon, one of three images does not overlap with other two. It shows a bit displacement (nearly half pixel). Hence I can not go further with my analysis of forest change change.

To note, all layers/images have same datum/projection. I tried to image-to-image georegister the non-overlapping image with another image to nearly 0 rmse accuracy. However, when I clipped/extracted the study area portion again from this image with that polygon, the image again was not overlapping with the other two!

How can I get all these images spatially overlap completely?

What are the possible problems which might arise in finding forest cover and biomass change for 3 time-series years using those 3 images?

0 Kudos
1 Solution

Accepted Solutions
DanPatterson_Retired
MVP Esteemed Contributor

It is when you said 'clip'... I assume that the problem isn't one of gaps along the edges of rasters, but one when they are stacked.  This suggests that the Environments tab of the raster clip tool should be check and you should assign the snap raster there in the raster properties... I would have a look in any event.

View solution in original post

0 Kudos
8 Replies
DanPatterson_Retired
MVP Esteemed Contributor

If it were a single band raster, I would think you didn't set a Snap Raster in the Environments setting but I would also check your processing extent options

MohammadRedowan
New Contributor II

Thanks Dan. They were normal 6 or 7 bands rasters. What can I do in this case?

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

It is when you said 'clip'... I assume that the problem isn't one of gaps along the edges of rasters, but one when they are stacked.  This suggests that the Environments tab of the raster clip tool should be check and you should assign the snap raster there in the raster properties... I would have a look in any event.

View solution in original post

0 Kudos
MohammadRedowan
New Contributor II

Wao!!!!!!!!!!! So simple a solution but saved my life!

I showed the non-matching raster to snap to one of the other two matching rasters in the environment setting while clipping and it did the job!

Thank you so much Dan...

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Mohammad, perhaps you could mark the answer correct so that others know a solution was reached.

0 Kudos
Jayanta_Poddar
Honored Contributor

You should be able to get the desired result using Snap Raster (Environment Settings). Are you still getting the issue?

Do the pixels of the original rasters overlay correctly before they are clipped?

MohammadRedowan
New Contributor II

Thanks Jayanta, snapping option solved my problem. I killed long two days on this before posting here, believe me.

0 Kudos
Jayanta_Poddar
Honored Contributor

Glad it worked. I believe you have learnt many new things while "killing" those two days. Each failure is a learning in disguise. So, don't get disappointed.