RPC_E_SERVERFAULT Issue New to 10.4+

2481
3
04-05-2016 09:24 AM
Highlighted
New Contributor II

We are experiencing a new error from existing functionality in one of our applications. After testing, we have confirmed that the same functionality (which has not been changed), works correctly on ArcMap 10.2.2 and ArcMap 10.3.1. The issue started cropping up when we updated to ArcMap 10.4. When running on a Dev environment (running ArcMap via VS), ArcMap outright crashes. When running it standalone, we get this:

The server threw an exception. (Exception from HRESULT: 0×80010105 (RPC_E_SERVERFAULT))

Here's some simplified code to illustrate the issue...

IEnumerator windowIdEnum = null;

IQueryFilter pQF = null;

IFeatureClass fc = null;

IFeatureCursor cur = null;

try

{

     windowIdEnum = _aGlobalHashTable.Values.GetEnumerator();

     windowIdEnum.Reset();

     while (windowIdEnum.MoveNext())

     {

          try

          {

               pQF = new QueryFilterClass();

               pQF.WhereClause = "OBJECTID" + " = " + Convert.ToString(windowIdEnum.Current);

               fc = _aGlobalClass;

               cur = fc.Update(pQF, false); // Failing line!

          }

      }

}

3 Replies
Highlighted
New Contributor II

Hi Danielle... did you ever figure out what was causing this?  We've run into the same issue when upgrading to 10.4 for our addin.

Thanks!

Reply
0 Kudos
Highlighted
New Contributor II

Deidre, we have not yet figured out how to fix this and have also not heard anything from ESRI about it. It seems that 10.4.1 also has this issue, so I'm investigating some more. Have you had any luck with this problem?

Reply
0 Kudos
Highlighted
Occasional Contributor

I have recently upgraded to 10.4.1 from 10.1 and I cannot get past this issue. It has been many many months now. Did you get this resolved and if so how?

Edit: I found a workaround here: https://community.esri.com/message/629315-arcobjects-104-and-1041-selecting-features-net 

Reply
0 Kudos