workspace suddenly becomes read-only

41285
75
11-20-2012 06:17 AM
MatthewFoster
New Contributor II
Hi Everyone,
This is driving me crazy.  I will be working on editing a point shapefile (or feature class in a file geodatabase), adding points and an attribute for the ID as I go along.  I can save the edits as I go (and I do), but after a few saves, the shapefile or feature class suddenly becomes read-only - or at least, that is what ArcGIS tells me, "Unable to save edits. Workspace or data source is read only".  I never set anything to read only, and after successfully saving my file 3 times (in the latest case) it decides to give me this error on the fourth time!  I have tried putting the geodatabase in a different directory, I've tried as a shapefile... Any ideas?  This has happened repeatedly with different projects lately.  Very frustrating

Thanks in advance,

Matt
Tags (2)
75 Replies
JeffPatinio
New Contributor
Hi had the same issue when working with DEM files, how do I fix this?

Thank you!
0 Kudos
JeffJones2
New Contributor
Like many of you, I have been having this problem.  An earlier post mentioned it could be because of a service running in the background.  I use Dropbox.  So, I paused Dropbox from indexing and syncing.  Suddenly after re-starting ArcMap I was able to make the edits to a shapefile of zip code polygons that kept giving me this same error.

Try pausing Dropbox and see if this works for you.
0 Kudos
CourtneyStokes
New Contributor
I'm also getting the message that the workspace is read-only, except that it happens all the time and I can't ever edit anything. I've been using Arc at school, but got the educational 1-year license for my personal laptop (Windows 7). Everything seemed to install correctly, but when I put the folder with my geodatabase onto my laptop (from flash drive) it becomes read-only, and nothing happens when I try to change it back. This doesn't happen with any folders that don't contain a geodatabase. Any thoughts?
0 Kudos
JohnNiles
New Contributor III
Does ESRI staff even look at the forums? This problem persists and they hasn't even been any acknowledgement that it is a problem.
0 Kudos
alex_friant
Occasional Contributor II

Recently ran into the same issue, even with my file geodatabase on a local drive (ArcGIS 10.1, Windows 7).  I read this thread, did all of these things that have been suggested in this thread, and it seems to be working as it is supposed to now (able to save edits)!!!

  • closed all arcgis desktop applications down
  • terminated the ArcGISCacheMgr.exe in Windows Task Manager
  • performed the RegEdit registry "reset" (instructions are in this thread above)
  • made a copy of my file geodatabase, and "repaired geometry" on all feature classes
  • "paused" the syncing of DropBox & GoogleDrive services

I'll come back and edit this if the issue ever rears its ugly head again.

UPDATE:

It worked well for about 6 hours of editing with many saves.  But at the end of the day, I got the "can't save edits" bug again.  So we can rule out the DropBox and Google Drive Sync as the culprits.  The fix must of have come from the registry fix as my "repair geometry" earlier didn't fix any bad geometry.  So, this has got to be a bug in ArcGIS's ability to write correct registry settings to the Operating System, which eventually screws with Desktop's ability to maintain a "lock" on the file geodatabase files within the file geodatabase folder.

Well, hopefully an upgrade to Windows 8 and ArcGIS Desktop 10.2 will fix this bug.  It's pretty frustrating as one of the most fundamental GIS tasks is to edit data, and have the ability to save your edits.  In fact, it's one of the most basic functions of any computer program, really.

0 Kudos
WhitynOwen
New Contributor

Add another instance to the list. Has a solution been developed? Does a complete reinstall work?

Thanks!

UPDATE:

Load the ESRI Quality Improvement Patch for 10.1 SP1 developed this year, last updated May, 2014. It loads on top of SP1.

0 Kudos
PeterKing
New Contributor III

We had this same error with editing and replication since 10.1 was released. A little known Esri Quality Improvement Patch was released earlier this year for 10.1 SP1 users and can be found here ArcGIS 10.1 SP1 for (Desktop, Engine, Server) Quality Improvement Patch | Samples and Utilities . After installing the patch we do not have the "Read Only" any longer.

0 Kudos
JoshuaDamron
Occasional Contributor III

This issue seems to occur occasionally in 10.2 (currently running ArcMap Advanced/Catalog version 10.2.0.3384).  I got the "cannot save edits" unknown error occurred" while working with a polygon feature class in a file geodatabases, I am the sole read and read/write user of the geodatabase.  I was doing a lot of tracing of other features in my editing tasks, I believe the  trace errors that used to be expected in 9.3 are still creeping in the shadows of 10.2.  At some point while trouble shooting I got another error that said "cannot find GDB_Item" but I have no idea what that could mean.

I have not seen anyone suggest a work around, so here is something you can try so you don't loose your data next time:

The work around I found was to right click the layer I was working on and go Data>Export Data.  Not sure if there is something to this or not but as my first try at this my ArcGIS froze my CAD workstation or about 5 minutes, when it came around and I finally canceled the process.  Then I used Data>Export to CAD and locally saved the layer I was editing as a CAD file.  Reassured that my work was somewhere retrievable and not entirely lost I did Data>Export Data again with no problems.  I closed ArcGIS without saving my edits (since it would not let me save my edits) and then re-opened the .mxd.

The choice is yours whether to import the newly saved layer from the Data Export and copy/paste the edited features into the original feature class, or simply archive the original and adopt the export as your new working dataset moving forward.  If you do the latter you can import the layer symbology from the original layer, that get's you right back where you were like it was just bump in the road.

Hope that helps someone.

0 Kudos
SeanJones
Esri Regular Contributor

As noted above this has been fixed in 10.1 QIP and 10.2.1 as part of NIM-094612.

0 Kudos
MelissaJarman
Esri Contributor

The patch for 10.1 sp1 that Sean mentions can be found below or 10.2.1 or newer release can be used that includes this fix.

ArcGIS 10.1 SP1 for (Desktop, Engine, Server) Quality Improvement Patch | Samples and Utilities