When registering a new st_geometry enabled table with a SDE geodatabase, why can't enable M and Z values?

163
3
10-12-2017 11:40 AM
Highlighted
New Contributor III

I created a table in Oracle with sde.st_geometry as the shape, then tried to register it in Catalog (ArcGIS 10.3.1). But the options for enabling "Coordinates include M/Z values, Used to ..." are disabled.  On the other hand, if I create a feature class using the ArcGIS create feature class tool, I can specify enabling both of them. Anything I missed for the 1st method?

Reply
0 Kudos
3 Replies
Highlighted
Esri Esteemed Contributor

The spatial reference properties of a layer are established at creation. You can't add Z or M (or both) to an existing layer. What was the exact SQL you used to create the table?

- V

Reply
0 Kudos
Highlighted
New Contributor III

My sql is as simple as this "create table (x number,y,number,z number,shape sde.st_geometry)". Then I would use Catalog to register it as a feature class with geodatabase, such as adding objectid and setting coordinate system. First time trying to enable Z and M. Maybe for M and Z setting, the feature class needs to be created from Catalog?

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

You left off the registered rowid column. You should ALWAYS have a NUMBER(38) column.

Simple table creation likely defaults the SRID to zero, which doesn't have Z and M settings. I haven't used Oracle in a while so you 'll need to explore how to specify an appropriate spatial reference ID.

- V

Reply
0 Kudos