Transferred files without ArcCatalogue - can't open layers in ArcMap

2693
4
08-15-2014 09:49 AM
Highlighted
New Contributor II

Hi!

 

I transferred files from one computer to another just by copy/paste without using ArcCatalogue (yes, I am a beginner : ) and now the source computer is dead, so I can't do it properly anymore.

 

The files in the new computer are there, but GIS can't open them and the following Open Failed window appears: "Error opening feature class" and there are red exclamation marks beside my layers.

 

The individual files for a specific Shapefile Feature Class (.dbf, .sbn, .sbx, .shp, .shp.xml and .prj) all seem to contain the right information - for instance, I can open the .dbf files in Excel and it contains the right information. My understanding is that all files are not linked together the right way.

 

Is there a way to restore the integrity of the files?

 

Thank you very much for the help!!

Raph

Reply
0 Kudos
4 Replies
Highlighted
Regular Contributor III

You will have to resource the data in the MXDs to point to the new data locations.

Highlighted
New Contributor II

Hi Asrujit SenGupta, Thank you very much for your reply! I did as you instructed. I did it in ArcCatalogue (righ-click on MXD file > Set data source(s) > replaced New data source). It is working well for rasters, but not for shapefiles. When I look in properties of each shapefile in ArcMap, the location of the data source is fine, but it cannot be read/displayed properly. When I try to replace file location in ArcMap for each individual layer (properties > source > Set Data Source) it gives me the following message "Error setting the data source". What am I doing wrong? Thank you! Raph

Reply
0 Kudos
Highlighted
Regular Contributor III

Are you able to add Shapefiles into ArcMap from the new location w/o any error?

Reply
0 Kudos
Highlighted
New Contributor II

No, only the raster files. I can add shapefiles from other locations no problem, but can't reassign successfully a location to my shapefiles of interest.

Reply
0 Kudos