Schedule for ArcSDE 10.3 release?  (for NIM-099594 issues)

5789
11
04-09-2014 10:07 AM
Highlighted
New Contributor III
Hello -

Does anyone have information as to when ArcSDE 10.3 is scheduled for release?  We are beginning to have big problems with a known bug (NIM-099594) which is supposed to be fixed in 10.3.

Links to NIM-099594 and Knowledge Base article:

http://support.esri.com/en/bugs/nimbus/TklNMDk5NTk0
http://support.esri.com/en/knowledgebase/techarticles/detail/42335


Our current system:

Oracle 11g (11.2.0.1) - Linux RedHat 5.4 64-bit
ArcSDE 10.1 sp1
using ST_Geometry format


Our ArcSDE upgrade path has been:  (1)  9.3.1  (2) 10.0 sp5  (3) 10.1 sp1

My understanding is that the issue happens when ArcSDE is upgraded from 10.0 to 10.1.  If ArcSDE is upgraded from version 9.3.1 directly to 10.1 it doesn't happen.

The only work-around we've so far been successful with is to create new feature classes for the ones having this problem and load in the data from the original feature class.

We are also curious if others are running into this problem.

Thanks,

Ellen Dean
St. Johns River Water Management District
Reply
0 Kudos
11 Replies
Highlighted
Regular Contributor III
Ellen,

This is a critical issue as of now and I would suggest discussing it directly with ESRI Tech_Support. Some workarounds have been found, which the Tech Support analyst will analyse, if its applicable for you and then suggest accordingly.

As for the scheduled release of ArcGIS 10.3, I don't think anyone here is in a position to confirm that for you. Again Tech-Support would be a better way to confirm that.

Regards,
Reply
0 Kudos
Highlighted
Esri Esteemed Contributor
Esri has not yet announced the post-10.2 release, so it's a bit early to worry
about its release schedule.

- V
Reply
0 Kudos
Highlighted
MVP Regular Contributor
Esri has not yet announced the post-10.2 release, so it's a bit early to worry
about its release schedule.

- V


Announced or not, 10.3 is mentioned on the NIMBUS page as the release in which the fix is included:

Bug NIM-099594

Since the bug severity is set to high, I don't think we will see another 10.2.3, 10.2.4, ... 10.2.9 before going on with 10.3, will we? 😉

Anyway, 10.3 might spontaneously convert into 10.2.3...
Reply
0 Kudos
Highlighted
Esri Esteemed Contributor
No, the release named "10.3" in the NIMBUS article will not spontaneously
convert to 10.2.3 -- 10.2.2 is the end of the 10.2 line (at least until after the
new version is released).

I realize it's frustrating to wait on a critical fix, but there may be reasons why
it could not be fixed in the 10.2.x code base, and there isn't any way to push
the train out of the station while it's still taking on fuel, water, baggage, and
passengers.

- V
Reply
0 Kudos
Highlighted
New Contributor II
Will the QIP for 10.1 SP1 fix it? As Ellen noted in the original post, we are still at ArcSDE 10.1 SP1. Something in the knowledge base article http://support.esri.com/en/knowledgebase/techarticles/detail/42335 has me puzzled:

[INDENT]"This issue only exists in ArcGIS 10.2.1, (and will be resolved with the general patch for NIM099594), as well as 10.1 and 10.1 SP1 (resolved in 10.1 SP1 QIP)."[/INDENT]
This sounds like the QIP resolves the issue for those still at 10.1. Does it?

Thanks,
Chris Mundy
St. Johns River Water Mgmt District
Reply
0 Kudos
Highlighted
Esri Esteemed Contributor
This sounds like the QIP resolves the issue for those still at 10.1. Does it?


I'm not really sure, but I am sure that Tech Support will know.

- V
Reply
0 Kudos
Highlighted
Esri Contributor
There are 2 bugs mentioned in knowledge-base article 42335.

NIM099594 - Oracle errors, ORA-29877, ORA-20085 and ORA-06512 are encountered when attempting to make object schema changes, spatial index changes, add Global IDs, register data as versioned (Register as Versioned tool), or create a raster dataset in ArcCatalog after upgrading certain ArcSDE 10.0 Oracle geodatabases.

The following error messages may be returned:

"ORA-29877: failed in the execution of the ODCIINDEXUPDATE routine
ORA-20085: Insert Spatial Reference SRID 4326 does not match
SDE.GDB_ITEMS.SHAPE registered Spatial Reference SRID 0
ORA-06512: in "SDE.ST_DOMAIN_METHODS", line 2000
ORA-06512: in "SDE.ST_DOMAIN_METHODS", line 2372"



NIM095988 - When editing data that has been upgraded from ArcSDE 9.3 to ArcSDE 10.1, the following error is returned:

"ORA-20085: Insert Spatial Reference SRID 2274 does not match
dataowner.A833.SHAPE registered Spatial Reference SRID 3"


A general patch is being tested and is expected to be released soon for NIM099594 on ArcGIS 10.2.2, 10.2.1 and 10.1sp1+QIP.
A fix for NIM095988 is already available in 10.1sp1+QIP and 10.2.2. However, the patch for NIM099594 on ArcGIS 10.2.1 will also include the fix for NIM095988.
Reply
0 Kudos
Highlighted
Occasional Contributor
Any updates of the 'Spatial Reference Consistency Patch' for 10.2.2?

http://support.esri.com/en/knowledgebase/techarticles/detail/42335

http://support.esri.com/en/downloads/patches-servicepacks/view/productid/160/metaid/2095

we used "ArcSDE 10.2.2 Oracle Geodatabase Object Schema Update and Editing Patch"
http://support.esri.com/en/downloads/patches-servicepacks/view/productid/66/metaid/2083
and it does not fix the issue.
Reply
0 Kudos
Highlighted
Occasional Contributor
Now it seems more the "Bug:  Unable to insert or update Oracle st_geometry feature classes, encountering ORA-20085 errors"
http://support.esri.com/en/knowledgebase/techarticles/detail/42461
issue NIM095988 (http://support.esri.com/en/bugs/nimbus/TklNMDk1OTg4)

It is marked as solved in Nimbus, but with no solution in the bug report(?).

Any updates of the 'Spatial Reference Consistency Patch' for 10.2.2?

http://support.esri.com/en/knowledgebase/techarticles/detail/42335

http://support.esri.com/en/downloads/patches-servicepacks/view/productid/160/metaid/2095

we used "ArcSDE 10.2.2 Oracle Geodatabase Object Schema Update and Editing Patch"
http://support.esri.com/en/downloads/patches-servicepacks/view/productid/66/metaid/2083
and it does not fix the issue.
Reply
0 Kudos