Rectified images from ArcGIS 10.1 appear black in other software

09-05-2012 03:55 AM
New Contributor II
Since upgrading to ArcMap 10.1, my rectified images cannot be used outside of ArcMap.

The system is running Windows 7, 64 bit.

I sometimes have to provide rectified images for clients using other GIS software (MapInfo).

The rectified images appear just fine in ArcMAP but appear as solid black to any other software.
I know there is SP1 being released  next month, that I hope fixes this major problem.

Is there a work around for this besides downgrading to 10.0?

0 Kudos
17 Replies
New Contributor
I encountered the same problem, and I found that the images, once georeferenced, can be exported and the "no data value" set to 0 to fix the issue. (I haven't tried leaving it blank, but I'd assume that works as well)

FYI, my office runs a variety of Arc versions, from 10.1 to 9.3, all on machines running Windows XP.

We had the issue of the older 9.3 machines not being able to load in images georeferenced by 10.1 or 10.0 machines from a network drive.

Thank you for the fix suggestion!
0 Kudos
New Contributor

I was having this issue too -- thanks Travis for the suggestion. Changing NoData from "256" to blank fixed the problem. What's up with that?

BTW, Jeffrey Swain, I checked, and the bit depth had been upgraded to 24... strange!

Anyway, thanks for the suggestion!

0 Kudos
Regular Contributor

The promotion is most likely due to the resampling. When the raster is resampled the bit depth is promoted to allow for any change in spatial extent due to projection change or something else.  You can see this effect, by clipping a raster with a graphic selected by Data > Export data.  When you perform this, there will be a prompt asking you if you would like to promote the bit depth.  Say 'No' and it will remain the bit depth of the original. If you say 'Yes' then the exported raster will have the promoted bit depth. Since you said yours is 24 bit, then perhaps the originals were 16 bit? Just a guess.  Using the Copy Raster tool to turn it back down to the proper bit depth should work, provided you won't be losing any values in the process. 

0 Kudos
Occasional Contributor III

This issue was really screwing with me in CityEngine 2016.1.  I'm glad I found this post.

I can verify that this issue persists in ArcMap 10.3.1 and that setting the 'NoData Value (optional)' setting to 0 when using Clip (raster) is the only way to solve it.  It will set the 'Pixel Depth' to 8 Bit and the 'NoData Value' to 0, 0, 0.

Do not set the value to blank!  Blank sets the 'Pixel Depth' to 16 Bit and the 'NoData Value' to 256, 256, 256.

You can see the difference in Windows Explorer.

0 Kudos
New Contributor II

When you are exporting your image in ArcMap, do you keep the default values and just check the "Use Renderer" and the "Force RGB" boxes? I had the same issue and I solved it this way.

Source: 4th step in the ressource page ArcGIS Help 10.1

0 Kudos
Occasional Contributor III

Wow, this just happened to me in 10.6.1.  Did you guys really not fix this yet? Such that the default is a blank NoData field? I just wasted 20 min trying to figure this out

0 Kudos
New Contributor II

Just happened to me as well. Wasted over an hour testing different export settings and self-trouble-shooting. Entire georeferenced images were exporting as all black, even within ArcMap, and somehow even managing to mess up the control links on the image, e.g. after export, I was left with an all black image that was not in the position of the original georeference, e.g. image shifted 100 ft to the right. 

To fix:

Check the boxes: "Use Renderer" and "Force RGB" and set NoData value to 0.

0 Kudos
New Contributor III

Thanks Chris !!

and Jeremy of ESRI (for giving us some background to this).

This fixed the problem for me too!. I was doing almost 30 mins of trouble shooting and fortunately I came across this thread. ESRI should make a technical support article for this issue if they have not already done so, especially since people are still having to deal with this after 8 years.

There are many people like us using other 3D Modeliing software packages like Leapfrog 3D and Vulcan etc in conjunction with ESRI products and readily available knowledge of this issue would come in handy.

Thanks again,